I have an Ubuntu 18.10 dual boot with Windows 10. I think that because of the error below my Ubuntu crashes/hangs a lot lately at the time of reboot/startup.

$ sudo apt-get --with-new-pkgs upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-4.18.0-15 linux-headers-4.18.0-15-generic linux-image-4.18.0-15-generic linux-modules-4.18.0-15-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic
3 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 66.0 MB of archives.
After this operation, 329 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-modules-4.18.0-15-generic amd64 4.18.0-15.16 [13.4 MB]
Get:2 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-image-4.18.0-15-generic amd64 4.18.0-15.16 [8,154 kB]                     
Get:3 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-modules-extra-4.18.0-15-generic amd64 4.18.0-15.16 [32.7 MB]              
Get:4 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-generic amd64 [1,868 B]                                      
Get:5 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-image-generic amd64 [2,480 B]                                
Get:6 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-headers-4.18.0-15 all 4.18.0-15.16 [10.5 MB]                              
Get:7 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-headers-4.18.0-15-generic amd64 4.18.0-15.16 [1,195 kB]                   
Get:8 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 linux-headers-generic amd64 [2,440 B]                              
Fetched 66.0 MB in 2min 25s (456 kB/s)                                                                                                           
Selecting previously unselected package linux-modules-4.18.0-15-generic.
(Reading database ... 197143 files and directories currently installed.)
Preparing to unpack .../0-linux-modules-4.18.0-15-generic_4.18.0-15.16_amd64.deb ...
Unpacking linux-modules-4.18.0-15-generic (4.18.0-15.16) ...
Selecting previously unselected package linux-image-4.18.0-15-generic.
Preparing to unpack .../1-linux-image-4.18.0-15-generic_4.18.0-15.16_amd64.deb ...
Unpacking linux-image-4.18.0-15-generic (4.18.0-15.16) ...
Selecting previously unselected package linux-modules-extra-4.18.0-15-generic.
Preparing to unpack .../2-linux-modules-extra-4.18.0-15-generic_4.18.0-15.16_amd64.deb ...
Unpacking linux-modules-extra-4.18.0-15-generic (4.18.0-15.16) ...
Preparing to unpack .../3-linux-generic_4. ...
Unpacking linux-generic ( over ( ...
Preparing to unpack .../4-linux-image-generic_4. ...
Unpacking linux-image-generic ( over ( ...
Selecting previously unselected package linux-headers-4.18.0-15.
Preparing to unpack .../5-linux-headers-4.18.0-15_4.18.0-15.16_all.deb ...
Unpacking linux-headers-4.18.0-15 (4.18.0-15.16) ...
Selecting previously unselected package linux-headers-4.18.0-15-generic.
Preparing to unpack .../6-linux-headers-4.18.0-15-generic_4.18.0-15.16_amd64.deb ...
Unpacking linux-headers-4.18.0-15-generic (4.18.0-15.16) ...
Preparing to unpack .../7-linux-headers-generic_4. ...
Unpacking linux-headers-generic ( over ( ...
Setting up linux-headers-4.18.0-15 (4.18.0-15.16) ...
Setting up linux-modules-4.18.0-15-generic (4.18.0-15.16) ...
Setting up linux-headers-4.18.0-15-generic (4.18.0-15.16) ...
Setting up linux-image-4.18.0-15-generic (4.18.0-15.16) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.18.0-14-generic
I: /initrd.img.old is now a symlink to boot/initrd.img-4.18.0-14-generic
I: /vmlinuz is now a symlink to boot/vmlinuz-4.18.0-15-generic
I: /initrd.img is now a symlink to boot/initrd.img-4.18.0-15-generic
Setting up linux-modules-extra-4.18.0-15-generic (4.18.0-15.16) ...
Setting up linux-headers-generic ( ...
Setting up linux-image-generic ( ...
Setting up linux-generic ( ...
Processing triggers for linux-image-4.18.0-15-generic (4.18.0-15.16) ...
update-initramfs: Generating /boot/initrd.img-4.18.0-15-generic
I: The initramfs will attempt to resume from /dev/sda5
I: (UUID=09e25397-4a2c-4fb0-a605-a7013eecb59c)
I: Set the RESUME variable to override this.
Sourcing file `/etc/default/grub'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.18.0-15-generic
Found initrd image: /boot/initrd.img-4.18.0-15-generic
Found linux image: /boot/vmlinuz-4.18.0-14-generic
Found initrd image: /boot/initrd.img-4.18.0-14-generic
Found linux image: /boot/vmlinuz-4.18.0-13-generic
Found initrd image: /boot/initrd.img-4.18.0-13-generic
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
  • reference: https://help.ubuntu.com/community/UsingUUID
    – noobninja
    May 24, 2020 at 14:44
  • I don't see any "issues".
    – Pilot6
    Jan 18, 2021 at 12:16
  • I: is short for Information:, it's not an error, which would be E:
    – mook765
    Jan 29, 2021 at 10:25

3 Answers 3


The swap UUID needs to be added to the /etc/initramfs-tools/conf.d/resume file.

The following command can show what your swap UUID is:

blkid | awk -F\" '/swap/ {print $2}'

You can run the following to set that in the RESUME file (it will be created if it doesn't exist in that folder):

printf "RESUME=UUID=$(blkid | awk -F\" '/swap/ {print $2}')\n" | sudo tee /etc/initramfs-tools/conf.d/resume

Then run the following to update the kernels on the system:

sudo update-initramfs -u -k all

Reboot the system so the changes can take affect.

This does last through kernel updates.

Hope this helps!

  • 1
    For now, i am going to "accept" this answer, because i don't know what i did and until next kernel update, I hope it doesn't give me same warning. (How can i know if this method really worked instead of waiting kernel update?) @Terrance
    – Pranav
    Feb 9, 2019 at 7:11
  • @PrabeshBhattarai This is what I have had to do to my machine too. This happens when I install Ubuntu fresh on the system, but I allow it to pick the install, but I leave the old swap partition. Well, the install creates a swap file and then I change back to the partition instead of the file and I get this message because the resume was never created by default. This does last through kernel updates. Maybe I should add this to the answer.
    – Terrance
    Feb 9, 2019 at 14:43
  • I don't have the /etc/initramfs-tools/conf.d/resume file already present, is that an issue? Or shall I make a new file and add RESUME=... in that file? I just started linux, so please pardon if this is a primitive question. Jun 19, 2021 at 7:38
  • @YashvanderBamel The printf command above creates the file for you if it is not there.
    – Terrance
    Jun 19, 2021 at 14:36

I will add just one caveat.

The initramfs will attempt to resume from /dev/sda2
I: (UUID=139d357c-829d-408d-bccc-147ec4402da8)
I: Set the RESUME variable to override this.

The above was my case and the UUID stated there is the disk's (sda2 in my case) UUID, not the PARTUUID (i.e. the partition's UUID where the swap is installed).

This is so counter-intuitive, as the warning suggests, at least to me, that the disk's UUID was the problem!

But long story short, here is my solution:

Add the disk's UUID to the resume file not the partition's PARTUUID.

sudo gedit /etc/initramfs-tools/conf.d/resume

In my case I added:


And if this is not clear, my fstab for my swap location is:

/dev/sda2: UUID="139d357c-829d-408d-bccc-147ec4402da8" TYPE="swap"
PARTLABEL="HDD_Swap" PARTUUID="0067903b-aed0-48d1-8d59-956784616d48"
  • i'd come upon this error based on resizing my partitions/moving swap partition. in my case when running mkswap it returns a UUID and instructions i followed said to replace swap's UUID in /etc/fstab. using the same in /etc/initramfs-tools/conf.d/resume as well resolved the issue.
    – ben_wing
    Apr 8, 2020 at 3:22

I use LVM (for swap too) on ubuntu server 20.04 and after installing updates I received the mentioned messages:

Processing triggers for initramfs-tools (0.136ubuntu6.3) ... 
update-initramfs: Generating /boot/initrd.img->5.4.0-65->generic 
I: The initramfs will attempt to resume from /dev/dm-2 
I: (/dev/mapper/ubuntu--vg-ubusrv--lv--swap) 
I: Set the RESUME variable to override this. 

I added RESUME=/dev/mapper/ubuntu--vg-ubusrv--lv--swap to a file resume under /etc/initramfs-tools/conf.d.

update initramfs worked without any "I's" shown

Not the answer you're looking for? Browse other questions tagged or ask your own question.