I have used Grub Customizer to change the Boot Timeout to 4 seconds: Ubuntu 4.15.0-45 generic. The file has been changed but the Boot sequence always defaults to 30 seconds anyway. The 30 second delay appeared only recently before I attempted to correct the Timeout parameter. As it happens I dual boot Win10 but this makes no difference, even if I adjust the Win10 Timeout [which seems to apply to something else anyway].

The relevant file etc/default/grub is as follows:-

GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


I forgot to add that this is Ubuntu 18.04.2 LTS. Anyway if I click on the GRUB Customizer File tab and then Change Environment I can see that there is a red Exclamation mark at the DEVICEMAP_FILE: /boot/grub/device.map. Using the answer here /boot/grub/device.map is missing on Ubuntu 14.04. I can install the relevant file - this should sort out the problem, once I have saved the configuration with GRUB Customizer.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.