0

Using Rufus to create bootable image on mine windows 10 (The OS came with the laptop from the store) . Laptop model Lenovo Y720 ..

  1. I tried to create MBR/GPT partition schema with ISO mode (recomended) .
  2. I tried to create MBR/GPT partition schema with DD mode

3.The modes i tried to load mine usb and maybe overcome this problem , UEFI and Legacy .

The OS Ubuntu is up and running in all 3 cases ..

But when it come to partitions here it begins .

No root file system , well Ok i am trying to make one but , it won't let me for example . If i choose the 512 000MB partition creation it create for me only 1MB partition and 0MB partition . The problem is that i can't create any partition with volume i need and set it to root .. I tried anything + ext4 filesystem format .

Does anybody had this kind of problem ?

I got last Ubuntu version LTS downloaded today from their site .

The strange thing is that , on mine second laptop i tried to install Kali Linux and it required from me the DD mode for the OS image in order to work , but for this case i have no idea what i need to do ..

Mine home PC has Ubuntu installed exactly the same version and working good.

After trying to install another OS BackBox , i got the stack error when i moving during installation to the Installation type stage, when i click on change or '+' buttons in the menu to add or change partitions as above
i got this errors: For Ubuntu problem i don't have any stack trace ..

Installer crashed : Traceback (most recent call last): File "/usr/lib/ubiquity/plugins/ubi-partman.py",line 1293 in on_partition_list_new active self_.partman_dialog(devpart,partition) File "usr/lib/ubiquity/ubiquity/plugin.py",line 48,in wrapper , return target (self,*args,**kwargs,) File "usr/lib/ubiquity/plugins/ubi-partman.py",line 956, in partman_dialog Type_Error:'NoneType' object is not subscriptable

0

The USB flashing is your problem? If yes than i suggest using Etcher. It's really easy to use and does a great job. Only thing it'll take all the space on the USB, you can't flash just a partition like in Rufus.

  • Ok so there another program , but how it will help me ? Are you saying that all the pain because of Rufus (I using it every time and it worked ) ? – Maks.Burkov Feb 8 at 10:45
  • I tried,and got the same result .. – Maks.Burkov Feb 8 at 11:28
  • Seems i misunderstood your question, your problem is while installing Ubuntu? Ar you trying to install Kali, Ubuntu dekstop or server? – Cristian Vrinceanu Feb 8 at 11:40
  • Desktop , i will update mine question with new information above. – Maks.Burkov Feb 8 at 11:54
0

I have the same laptop as you. Basically I opened disk management in windows 10, created an empty partition for example 100g on my SSD, and then made a new partition on that. Then I booted into the Ubuntu installation, and chose custom install. I then chose that 100gb from the custom install.

Here is the help I followed:

How to use manual partitioning during installation?

Btw. remember to disable fast boot and secure boot in BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.