1

Coming from arch where i was unable to control brightness no matter what i tried, i realized that by using the nvidia-390 driver in ubuntu everything is working fine....BUT i have random crashes of the system. When I am using the nouveau drivers everything is fine BUT i do not have any control over the brightness of the screen. This is a hybrid laptop and i have intel graphics and nvidia quadro P1000 Currently I am using the nouveau drivers Picture showing the 2 drivers available

Also please note that the intel graphics is not recognized at all.

Some information about my system

01:00.0 VGA compatible controller: NVIDIA Corporation Device 1cbb (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 8429
    Flags: bus master, fast devsel, latency 0, IRQ 255
    Memory at e8000000 (32-bit, non-prefetchable) [size=16M]
    Memory at a0000000 (64-bit, prefetchable) [size=256M]
    Memory at b0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at 4000 [size=128]
    Expansion ROM at e9000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel modules: nvidiafb, nouveau

and

$ inxi -G
Graphics:  Card: NVIDIA Device 1cbb
           Display Server: x11 (X.Org 1.19.6 ) drivers: fbdev,nouveau (unloaded: modesetting,vesa)
           Resolution: 1920x1080@77.00hz
           OpenGL: renderer: llvmpipe (LLVM 7.0, 256 bits) version: 3.3 Mesa 18.2.2

I have also attempted to use the brightness-controller application but it has no effect.

How can I either fix the brightness using nouveau drivers or fix the random crashed with the nvidia driver?

0

Bios Upgrade:HP Firmware Pack (Q71) 01.08.00 Rev.A 18.9 MB Aug 14, 2019

Nvidia Driver upgrade from 390 -> 430 (using ubuntu 18.04 proprieraty drivers)

Resolved my issues with instability/crashes AND brightness buttons

  • updated just before, 5 min later still crashes. I am on ubuntu 19.04 currently with nvidia-driver 430 – kampias Aug 22 '19 at 11:37
  • im on 18.04 with kernel 5.0.0.25 , my crashes occured only after waking up from hibernation, which seems to be fixed. – skurk Aug 22 '19 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.