0

I am trying to dual boot Ubuntu 18.04.1 LTS with my Windows 10 Acer Nitro 5 laptop. I made a 90GB partition, got a bootable USB, and booted into it and clicked Try Ubuntu without installing like the video I followed said, the video used Etcher but I used Rufus (if it makes a difference).

I got into Ubuntu, without installing, and nothing works. I see the screen, but I can't use the touchpad or click, I can move the cursor with a wireless mouse but I still can't click on anything. I've tried all the hotkey combinations, Alt Ctrl F1-F12, nothing, Alt Ctrl t. The keyboard doesn't work either then, I suppose.

My specs are 1TB HDD, 8GB DDR4, a GTX 1050 4GB, and an i5 if any of that matters.

What could be the cause of any of this?

  • 1
    You need to boot the installation media with an additional boot parameter - nomodeset - and also when booting the installed system until you install the Nvidia proprietary drivers. Please ignore the answer you had, don't waste time with it. – GabrielaGarcia Feb 8 at 14:25
  • How would I go about doing these things? Thank you – KalasiDibil14 Feb 11 at 9:19
  • You can try according to this link, Boot option nomodeset, Proprietary driver and links from it. – sudodus Feb 13 at 7:29
-1

I don't know if this helps, but I had a similar problem with similar specs. It turned out to be the USB drive I was using to boot the installer. It was a legacy drive and my BIOS was set not to allow legacy boot devices. When I created a new install on a different USB drive it worked perfectly.

  • So just create a different USB? How would I create one that isnt legacy? What is legacy anyways? I'm so new to all of this haha! Thanks in advance – KalasiDibil14 Feb 8 at 1:45
  • legacy would be anything pre-dating UEFI. In my case I had a cheap USB drive and thought they were all the same. The USB drive would need to support UEFI so that it installs the partition as UEFI. In my case the Windows partition was already UEFI friendly and I needed to match the Ubuntu install to it so that they would both use the same boot menu. – Kevin C Feb 8 at 1:58
  • I have 2 USBs, I used one with etcher and the other with rufus, my rufus settings are; Partition scheme MBR, Target system BIOS or UEFI, nothing in advanced driver properties is checked, File system is FAT32, cluster size is 16kilobytes default, and quick format and create extended label and icons is checked, but when I click START I get a popup saying "Download required: This image uses Syslinux 6.03/20171017 but this application only includes the installation files for 6.03 2014-10-06. As newer versions of syslinux arent compatible.It wouldn't be possible for rufus to include them all. – KalasiDibil14 Feb 8 at 6:15
  • It prompts me to download two additional files called Idlinux.sys and Idlinux.bss, it also says "Note: The files will be downloaded in the current application directory and will be reused automatically if present" Does this mean I should re download ubuntu so its fresh without those files and try it on etcher? I used rufus first so it added those files and then etcher, etcher doesnt say anything but after it's done it shows 1 failed device saying "PhysicalDrive2 Verification Failed" – KalasiDibil14 Feb 8 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.