0

when i installed and runed

msfconsole

there is an error like this

Ignoring bcrypt-3.1.12 because its extensions are not built. Try: gem pristine bcrypt --version 3.1.12
Ignoring bcrypt_pbkdf-1.0.0 because its extensions are not built. Try: gem pristine bcrypt_pbkdf --version 1.0.0
Ignoring ed25519-1.2.4 because its extensions are not built. Try: gem pristine ed25519 --version 1.2.4
Ignoring eventmachine-1.2.7 because its extensions are not built. Try: gem pristine eventmachine --version 1.2.7
Ignoring executable-hooks-1.6.0 because its extensions are not built. Try: gem pristine executable-hooks --version 1.6.0
Ignoring gem-wrappers-1.4.0 because its extensions are not built. Try: gem pristine gem-wrappers --version 1.4.0
Ignoring http_parser.rb-0.6.0 because its extensions are not built. Try: gem pristine http_parser.rb --version 0.6.0
Ignoring msgpack-1.2.6 because its extensions are not built. Try: gem pristine msgpack --version 1.2.6
Ignoring network_interface-0.0.2 because its extensions are not built. Try: gem pristine network_interface --version 0.0.2
Ignoring nokogiri-1.10.1 because its extensions are not built. Try: gem pristine nokogiri --version 1.10.1
Ignoring pcaprub-0.13.0 because its extensions are not built. Try: gem pristine pcaprub --version 0.13.0
Ignoring pg-0.20.0 because its extensions are not built. Try: gem pristine pg --version 0.20.0
Ignoring pg_array_parser-0.0.9 because its extensions are not built. Try: gem pristine pg_array_parser --version 0.0.9
Ignoring redcarpet-3.4.0 because its extensions are not built. Try: gem pristine redcarpet --version 3.4.0
Ignoring sqlite3-1.3.13 because its extensions are not built. Try: gem pristine sqlite3 --version 1.3.13
Ignoring thin-1.7.2 because its extensions are not built. Try: gem pristine thin --version 1.7.2

[!] There was an error parsing `Gemfile`: Illformed requirement ["1.10.1 ruby java x64-mingw32 x86-mingw32"]. Bundler cannot continue.

 #  from /opt/metasploit-framework/Gemfile:47
 #  -------------------------------------------
 #  
 >  gem 'nokogiri', '1.10.1 ruby java x64-mingw32 x86-mingw32'
 #  gem 'rex-socket', '0.1.15'
 #  -------------------------------------------

someone tell me how to fix this?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.