This question already has an answer here:

I am facing some issues when i am trying to write sudo command. Ex. If i run $ sudo -i command then i got - This errors : sudo: /etc/sudoers is world writable sudo: no valid sudoers sources found, quitting sudo: unable to initialize policy plugin

Please help to solve this errors. Thank you.

marked as duplicate by karel, Melebius, George Udosen, waltinator, Kulfy Feb 7 at 14:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Error message is self explaining. You should change permissions of /etc/sudoers, but root is needed for that so do from recovery mode:

chown root:root /etc/sudoers
chmod 0440 /etc/sudoers

Check content of file, make sure your username is there, so you allowed to use sudo. Thats all. reboot

  • Sorry.. I tried it but it's not working. – Siddhi Feb 8 at 9:19
  • pkexec chmod 0440 /etc/sudoers This command is solve this Problem. :) – Siddhi Feb 8 at 9:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.