I can't get rid of a proxy configured in Ubuntu 16.04.

I have tried the solutions suggested here, but did not resolved my situation:

How to permanently disable http_proxy

How to disable proxy in Ubuntu 16.04 LTS

How to remove proxy permanently from ubuntu>

The command env | grep proxy return nothing.

The network setting GUI is configured to None and Applied system wide.

I have removed the line of the proxy from /etc/apt/apt.conf, now is empty. Already rebooted the system (note: shut-down then power on, not just pressed reboot).

I have removed git and installed again but no luck.

If try to clone a repository from git, i still get errors because of the system is trying to connect to the proxy (i have not copied the github url and proxy ip in clear):

git clone https://github.com/xxxxxxx/xxxxxxx.git

Cloning into 'xxxxxxx'...
fatal: unabke to access 'https://github.com/xxxxxxx/xxxxxxx.git/': Failed to connect to XXX.XX.XXX.XXX port 8080: Connection timed out.

I i run apt command, for example apt-get update it does not try to connect to the proxy, and work properly.

How can i remove this proxy? Thank you

  • 1
    Is it perhaps a git specific proxy? does anything show up in git config -l ? – steeldriver Feb 7 '19 at 11:33

The command git config -l returned:


So it's a git specific proxy. Resolved by the command:

git config --global --unset http.proxy

Now git config -l return:


And git clone works properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.