0

I'm running Ubuntu 18.04.01 LTS. I have a Canon TS3129 Multifunction printer/scanner. Printer works fine, is recognized in devices. Network printer over wifi.

Trying to get the scanner function recognized and functioning.

Downloaded driver scangearmp2-3.50.1-deb,tar.gz. from Canon site.

Driver installed normally. Scanner function still not showing up anywhere.

Have tried SimpleScan, SKanlite, and XSane. None can find the scanner.

Have tried to find/use the scangear application - it seemed to install properly, but is nowhere to be found.....

I've read through many threads related to this, tried a few methods. I tried the command scanimage -L , it said no scanner found.

What am I missing/doing wrong?

1

might be a bit late but if not, hopefully it helps. I have a recently purchased Canon TR4500. Here's what I did.

Download cnijfilter2-5.70-1-deb.tar.gz from the Canon site, extract and run the install file as root.

Download scangearmp2-source-3.70-1.tar.gz from the Canon site, extract and run the install file as root.

During the install of scangearmp2, it complained that it could not find canontr4500.ppd. It was looking in the wrong directory. Copy it from /usr/share/ppd/ to /usr/share/cups/model

To launch the scanner device run scangearmp2 from a command line or create a launcher to /usr/bin/scangearmp2.

I haven't figured out how to make it work with the default Linux scan apps yet.

| improve this answer | |
  • yes, typo in my post there - fixed – mikeg Jan 31 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.