0

I recently installed docker following instructions outlined here:

https://docs.docker.com/install/linux/docker-ce/ubuntu/

I know this question has been asked a lot on different forums but most dont refer to my very basic problem and the others have solutions that didnt work.

The installation finished without any errors but when I enter the command:

$sudo docker run hello-world

I get the following error:

docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.

'docker' is in the list of groups for the current user and I tried the command with docker running and stopped.

I have tried the steps outlined in the post-installation steps here: https://docs.docker.com/install/linux/linux-postinstall/

Which are essentially the same steps outlined here: https://stackoverflow.com/questions/21871479/docker-cant-connect-to-docker-daemon?rq=1

With no luck

When I enter:

sudo systemctl start docker

I get the output:

Running in chroot, ignoring request

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.