1

I want to use an external monitor (Dell U3014t) connected through HDMI to a Ubuntu 18.04 laptop with the GeForce MX130 GPU.

When changing settings in "displays" GUI, the max resolution that works is 1920x1200. When set to 2560x1600, the monitor is black (no signal).

By adding new modes to xrandr I was able to get 2560x1600 working, but at most at 30 Hz.

I've tested with nvidia drivers 390, 396, 410 and 415 and it makes no difference.

Do you have any ideas how to get it running at 60 Hz? On Windows 10 it works fine.

relevant lspci output:

02:00.0 3D controller: NVIDIA Corporation GM108M [GeForce MX130] (rev a2)
    Subsystem: Dell GM108M [GeForce MX130]
    Flags: bus master, fast devsel, latency 0, IRQ 129
    Memory at ec000000 (32-bit, non-prefetchable) [size=16M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Memory at d0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at 3000 [size=128]
    [virtual] Expansion ROM at ed000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

00:02.0 VGA compatible controller: Intel Corporation Device 3e9b (prog-if 00 [VGA controller])
    Subsystem: Dell Device 0818
    Flags: bus master, fast devsel, latency 0, IRQ 128
    Memory at eb000000 (64-bit, non-prefetchable) [size=16M]
    Memory at 80000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 4000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.