4

I have installed VMRC on my computer. It seems to connect just fine, but the graphics of the remote server doesn't seem to render. I can connect to the host computer just fine, so it doesn't seem to be the host.

I've tried searching for missing libraries, but I've found nothing.

I'm running Nvidia 415 drivers with Intel selected as Prime profile on Ubuntu 18.04.

Some additonal specs:

Kernel: Linux * 4.15.0-45-generic #48-Ubuntu SMP Tue Jan 29 16:28:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
OS: Ubuntu 18.04.2 (Gnome)

I've tried both Wayland and Xorg, Wayland gives a black screen, Xorg gives the image below.

I've also tried to run it on my desktop PC (also with Ubuntu 18.04), it has an GTX 1080 running Nvidia 415 drivers. It has the same problem.

Graphical glitches

The scribbled lines are edited.

1

I had the very similar problem. In my case the cause of the problem was scripts created by elementary-os in /etc/profile.d/ :

gtk-csd.sh 
qt-style-override.sh 
qt-qpa-platformtheme.sh 

that set environmental variables preventing VMRC from proper rendering content area. I had removed them an it resolved the problem.

As you use elementary os probably this solution will not satisfy you, however you can try to run env GTK_CSD=0 vmrc -H your.vmware.host to check if it would resolve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.