0

we have a (windows) ntp server to witch we pull for time service. Connection en rights are oke. When we restart our virtual ubuntu 14.04 server the offset is within 20ms but after 60 sec the offset jumps to over 68000ms. This is a bit of a problem (understatement) because its a postgres server.

result ntpq -cpe -cas

remote refid st t when poll reach delay offset jitter

10.100.100.4 185.51.192.34 3 u 26 64 377 0.684 69771.3 154.202

+10.100.100.5 10.100.100.4 4 u 29 64 377 0.659 69776.2 166.560

ind assid status conf reach auth condition last_event cnt

1 45921 961a yes yes none sys.peer sys_peer 1

2 45922 942a yes yes none candidate sys_peer 2

connection seems oke. anyone any idea why the time keeps jumping back to the uge offset? Or where i can search for the reason why this is happening

  • did a grep on the syslog after setting date -t manually: Feb 6 13:18:30 lsass: [lsass] Failed to sync system time [error code: 40075] Feb 6 13:18:34 ntpd[7847]: 0.0.0.0 c61c 0c clock_step +69.895747 s Feb 6 13:19:43 ntpd[7847]: 0.0.0.0 c614 04 freq_mode Feb 6 13:19:44 ntpd[7847]: 0.0.0.0 c618 08 no_sys_peer – wduizer Feb 6 '19 at 12:24
  • Please edit your question and format both the command output and the log messages correctly. – Paul Gear May 15 '19 at 9:31
0

Some possible problems with your Ubuntu VM are:

  1. You have time sync with the host enabled (this is common on VMware and Hyper-V systems) and it is interfering with NTP's ability to set the virtual system clock.

  2. The host on which you are running your Ubuntu VM is under heavy load and/or has an inaccurate hardware clock.

Post your NTP configuration and we may be able to make further suggestions.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.