0

I want to sudo apt-get upgrade But it says that

The following packages have unmet dependencies: apt : Depends: libgnutls30 (>= 3.6.5) but 3.5.18-1ubuntu1 is installed

However, I actually just have run sudo dpkg -i libgnutls30_3.6.6-2_amd64.deb previously.

(At that time, the terminal returned:

  • dpkg-deb (subprocess): cannot copy archive member from 'libgnutls30_3.6.6-2_amd64.deb' to decompressor pipe: unexpected end of file or stream
  • dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
  • cannot copy archive member from 'libgnutls30_3.6.6-2_amd64.deb' to decompressor pipe: unexpected end of file or stream

)

If I execute dpkg -l libgnutls30, the detailed information says that the version is 3.5.18.

Please help, thank you.

0

From other forums, I found the solution. The root cause is that the download is corrupted. So I re download again, namely, I execute

wget http://ftp.br.debian.org/debian/pool/main/g/gnutls28/libgnutls30_3.6.6-2_amd64.deb

again.

The system automatically named it libgnutls30_3.6.6-2_amd64.deb.2

And then we can run dpkg -i libgnutls30_3.6.6-2_amd64.deb.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.