2

I am kinda new to terminal stuff and I need your help. I tried to install XArp on my machine with dpkg, but it needs packages, that I don't know how to install. I only tried to install libwxgtk2.8-0, but it can't be found. Here is what it says:

dave@dave-HP-ProDesk-600-G2-SFF:~$ sudo dpkg -i xarp-2.2.2-amd64-ubuntu-10.04.1.deb
(Reading database ... 345629 files and directories currently installed.)
Preparing to unpack xarp-2.2.2-amd64-ubuntu-10.04.1.deb ...
Unpacking xarp (2.2.2) over (2.2.2) ...
dpkg: dependency problems prevent configuration of xarp:
 xarp depends on libwxgtk2.8-0 (>= 2.8); however:
  Package libwxgtk2.8-0 is not installed.
 xarp depends on libxerces-c3.1 (>= 3.1); however:
  Package libxerces-c3.1 is not installed.
 xarp depends on menu; however:
  Package menu is not installed.
 xarp depends on arptables; however:
  Package arptables is not installed.

dpkg: error processing package xarp (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
 xarp

Thank you for help:)

  • What OS version are you using? It looks to me like you're trying to use an Ubuntu Lucid (10.04) package. These packages are likely 'too old' in terms of dependencies and software versions to work properly... – Thomas Ward Feb 4 at 20:02
  • @ThomasWard I am using 18.04. What should I do, if it is "out of date"? – Dave_5999 Feb 4 at 20:28
  • @N0rbert I don't think so, but I might be wrong. – Dave_5999 Feb 4 at 20:36
  • Then please shed some light on the source of xarp deb archive. Where did you downloaded it? Why does it named ...10.04.? – N0rbert Feb 4 at 20:38
  • @N0rbert it's from official web xarp.net Maybe it's just outdated program and I need to use something else. – Dave_5999 Feb 4 at 20:40
1

The dependencies of Xarp package are not contained in 18.04 LTS repository, but we can get and install them from 14.04 LTS repository manually (be careful, they will not receive any security updates) with steps below:

wget http://security.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.50-1ubuntu2.14.04.3_amd64.deb
sudo apt install ./libpng12-0_1.2.50-1ubuntu2.14.04.3_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxbase2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb
sudo apt install ./libwxbase2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxgtk2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb
sudo apt install ./libwxgtk2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/universe/x/xerces-c/libxerces-c3.1_3.1.1-5.1+deb8u4build0.14.04.1_amd64.deb
sudo apt install ./libxerces-c3.1_3.1.1-5.1+deb8u4build0.14.04.1_amd64.deb

sudo apt install ./xarp-2.2.2-amd64-ubuntu-10.04.1.deb

and enjoy:

$ xarp --version
XArp - Advanced ARP Spoofing Detection
version XArp 2.2.2
  • Thank you very much, for the help! But when I run $ xarp --version I yet get this: Gtk-Message: 21:57:31.413: Failed to load module "overlay-scrollbar" Gtk-Message: 21:57:31.606: Failed to load module "canberra-gtk-module" – Dave_5999 Feb 4 at 21:01
  • Use sudo apt install overlay-scrollbar-gtk2 libcanberra-gtk-module to remove these messages. – N0rbert Feb 4 at 21:54
0

You have dependencies issue. It means that package you want to install manually requires another packages to be operational. Try to execute apt install -fatrer dpkg This should fix dependencies issue.

  • I already did this, but it is still the same. But thanks – Dave_5999 Feb 4 at 20:30
0

First install "apt install -f " then try to install Team Viewer by using this command sudo dpkg -i teamviewer_14.4.2669_amd64.deb

  • 2
    Are you sure that you answered the right question? – karel Aug 2 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.