2

(http://paste.ubuntu.com/p/6P8bhRK5Gr/)

I am working on a Acer Aspire ES17 which previously had windows 10 installed. I want to remove windows 10 completely and use Ubuntu.

Using Rufus i made a bootable Ubuntu USB, Booted it and tried to install Ubuntu. The screen freezes at "Installing Grub 2" and Boot-repair freezes with "Reinstalling Grub 2". I left in on for a whole night yesterday and it was still frozen. Also tried boot-repair bootable usb. same thing.

I already tried to make an 1mb partition with bios_grub flag. Boot-repair returns with make a EFI partition and flag it as boot.

In BIOS i have EUFI, i cannot choose anything different like Legacy. Secure boot is turn OFF.

I have set Secure boot ON and set a password to enable Trust and add a file to the EFI. However i never see the option to add a trusted file.

Right now i am trying boot-repair again it comes with. "Please enable a repository containing the [grub-efi-amd64-signed] packages in the software sources of Ubuntu 18.04.1 LTS (sda2). Then try again." I don't know what to do? And if it will fix my issue.

Hopefully someone can help. Thank you in advance.

Update: ls/boot/efi shows: EFI FSCK0001.REC FSCK0003.REC FSCK0005.REC FSCK0000.REC FSCK0002.REC FSCK0004.REC boot. What are those files??? i used this page:https://www.rodsbooks.com/refind/installing.html#linux On the following line: On a UEFI-based system, type efibootmgr -c -l \EFI\refind\refind_x64.efi -L rEFInd to add rEFInd to your EFI's list of available boot loaders, which it stores in NVRAM. My pc crashed.... So everytime grub2 or anything else tries to add or adjust efi files it crashes. Is NVRAM broken? something must be broken? i can't find any other threads with a similar problem.

Update2: I recreated all partitions and did refind-install, PC froze but recovered after 10min. Showed internal error Title : systemd-logind crashed with SIGABRT in epoll_wait(). PC booted showing "no bootable device", no trust settings, tried installing ubuntu again it failed with unable to install efi. Tried boot-repair again, pc crashes when "Installing for x86_64-efi platform.

Update 3 and last: Took the laptop to a expert. Not possible to install Ubuntu due to some security on the BIOS/UEFI.

14
  • If you have Internet wired or wireless working and are using the same installer, the repository should already be enabled. It is more when using one installer for a different install that you actually need that. It looks like install is complete. But you have old UEFI entry for both Ubuntu & Debian, which you should delete first. And with Acer you need to enable trust. askubuntu.com/questions/429610/… & askubuntu.com/questions/908854/… – oldfred Feb 4 '19 at 19:10
  • Thanks for the reply, i am trying to delete boot0002-0003 ubuntu and debian but everytime is use sudo efibootmgr -b 0002(or any other) -B the laptop freezes. I also can't get the "Select an UEFI file as trusted for executing" line to show up in the BIOS. Supervisor password = set, password on boot = enabled, secure boot = enabled. hit f10 to try again still nothing. Is it maybe because the installation i did never finished. I know grub2 package never completed installation it always crashed. – savda Feb 4 '19 at 20:18
  • Have you updated UEFI from Acer? Many with those issues needed the UEFI update. Some very old threads may show downgrading UEFI to an older version, but all the newer threads say the update to new UEFI works. Acer Very latest UEFI/BIOS works, downgrade not required if no trust screens, you must now upgrade: ubuntuforums.org/… – oldfred Feb 4 '19 at 21:28
  • I used Hiren's BootCD to download an install the latest BIOS update v1.18. Retried to get the Select an UEFI file... to show up but it didn't. I tried boot-repair again same message, i tried installing Ubuntu again and again it fails at Installing 'grub2'package.. I have run out of ideas. Try old BIOS? – savda Feb 5 '19 at 22:18
  • If you are forcing a reboot with power switch, you may be corrupting or did corrupt file system. I would run fsck on every ext4 partition and dosfsck on ESP. askubuntu.com/questions/862724/grub2-failed-to-install/… & askubuntu.com/questions/642504/… – oldfred Feb 5 '19 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.