5

Trying to use Globus Personal Connect on my Ubuntu 16.04, and it requires Tcllib. I have tcllib installed (the newest version), but it still says "Tcllib not found" when I try to access the Globus Connect via "./globusconnect" command.

$ sudo apt-get install tcllib
[sudo] password for usdandres: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
tcllib is already the newest version (1.17-dfsg-1).
0 upgraded, 0 newly installed, 0 to remove and 50 not upgraded.

$ ./globusconnect
Tcllib not found.
The Globus Connect Personal GUI requires Tcllib.
Please install Tcllib using your distributions package management system.
On Debian based systems (e.g. Ubunutu):
  apt-get install tcllib
On Redhat based systems (e.g. CentOS, Fedora):
  yum install tcllib

 Note: if you encounter an error about tcllib not being
 available, it can be found here and installed manually:
 http://www.tcl.tk/software/tcllib/

You may also run Globus Connect Personal in CLI mode.

Please use the -help option or visit http://globus.org/globus-connect-personal/
for more information.

Any ideas on how to deal with this issue?

1
  • I encountered this problem trying to compile linuxcnc, my solution was sudo apt-get install tcl8.6-dev tcl-dev
    – j0h
    Commented Jul 20, 2021 at 2:14

2 Answers 2

2

I came across the same problem on Ubuntu 18.04 LTS with Globus Connect Personal 2.3.6. In my case the problem appears to have been caused by my Anaconda installation obscuring the Tcllib installed by the package manager. Creating and activating a new conda environment did not resolve the problem, nor did trying to install tcl from conda. My workaround was to temporarily remove the path to Anaconda from my PATH environment variable for the bash session in which I run ./globusconnect.

3
  • 1
    I'm just getting started with ubuntu and I think I might have the same problem. Can you describe the code you used to temporarily remove the path to Anaconda and then put it back?
    – Nova
    Commented Apr 8, 2019 at 13:51
  • @Nova, there are probably better ways, but I did echo $PATH, copied the output without the path involving anaconda3/bin and then set the PATH= the rest of the sequence output. Commented Jun 11, 2019 at 7:41
  • If you start a new terminal session, anaconda will automatically be included in your $PATH again. Otherwise you can reset the PATH= back to the original path including anaconda once you are done with globusconnect. Commented Jun 11, 2019 at 7:46
2

On my Ubuntu 16.04 LTS VM I have successfully launched it with:

cd ~/Downloads
wget https://downloads.globus.org/globus-connect-personal/linux/stable/globusconnectpersonal-latest.tgz
tar -xf globusconnectpersonal-latest.tgz
cd globusconnectpersonal-2.3.6/
sudo apt-get install tcllib tcl tk

and got its window after execution of ./globusconnect.

If you suspect that Anaconda is a problem and fear to break it, then you can manually change the PATH variable with

export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"

and then try to launch it from the same terminal with

./globusconnect 

Or in one-line version:

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games" ./globusconnect

7
  • This resulted in the same error for me.
    – Nova
    Commented Apr 8, 2019 at 14:00
  • Are you running 64-bit OS or 32-bit? What is the output of arch command?
    – N0rbert
    Commented Apr 8, 2019 at 14:29
  • 64 bit, x86_64. I know that Anaconda is installed on my computer so I'm concerned I have the same issue as @climatestudent. I'm such a Ubuntu noob that internet searches aren't getting me anywhere and I'm worried about messing up my .profile files.
    – Nova
    Commented Apr 8, 2019 at 14:39
  • 1
    Then try to manually specify PATH variable by export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games" and try to launch ./globusconnect then from the same terminal.
    – N0rbert
    Commented Apr 8, 2019 at 14:41
  • I can see that I have a number of files... .bash_profile, .bashrc, .bashrc-anaconda3.bak, and .profile
    – Nova
    Commented Apr 8, 2019 at 14:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .