I know there are alot of previous questions on this topic, but I've tried alot of the solutions and nothing has been working. I ran boot-repair on ubuntu and here is the pastebin link it gives: http://paste.ubuntu.com/p/VKwZsFmv7n/

Before running boot-repair, I could see on GRUB: Ubuntu, advanced options for Ubuntu, and Windows startup manager. Loading Ubuntu works fine, but trying to load into Windows 10 brought up a continuous loop of a screen "Could not startup Windows" with options to restart or go to advanced options. Eventually I decided to perform a factory reset through the advanced options, but Windows 10 still could not be booted into.

After running boot-repair, the GRUB menu has many more items with titles like "...windows..efi". Starting into some of them brings up a black screen with text: "no image found", and others bring me to a screen that lets me factory reset once again, or attempt to repair boot (I've tried both of these many times, no solution found yet).

Desperate for any help now into being able to boot into Windows 10 again, thanks in advance for any help.

Edit: sudo parted -l gives

Model: NVMe Device (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  683MB  682MB   fat32        EFI system partition          boot, esp
 2      683MB   817MB  134MB                Microsoft reserved partition  msftres
 3      817MB   220GB  219GB   ntfs         Basic data partition          msftdata
 7      220GB   241GB  21.0GB  ext4
 4      241GB   242GB  1038MB  ntfs                                       hidden, diag
 5      242GB   255GB  13.3GB  ntfs                                       hidden, diag
 6      255GB   256GB  1152MB  ntfs                                       hidden, diag

and grep -A10 -i 'Windows' /boot/grub/grub.cfg gives

menuentry "Windows UEFI bootmgfw.efi" {
search --fs-uuid --no-floppy --set=root D85B-0CB1
chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi

menuentry "Windows Boot UEFI loader" {
search --fs-uuid --no-floppy --set=root D85B-0CB1
chainloader (${root})/EFI/Boot/bkpbootx64.efi

menuentry "Windows Boot UEFI fbx64.efi" {
search --fs-uuid --no-floppy --set=root D85B-0CB1
chainloader (${root})/EFI/Boot/fbx64.efi

menuentry "EFI/ubuntu/fwupx64.efi" {
search --fs-uuid --no-floppy --set=root D85B-0CB1
chainloader (${root})/EFI/ubuntu/fwupx64.efi

menuentry "EFI/ubuntu/mmx64.efi" {
menuentry 'Windows Boot Manager (on /dev/nvme0n1p1)' --class windows --class os $menuentry_id_option 'osprober-efi-D85B-0CB1' {
    insmod part_gpt
    insmod fat
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root  D85B-0CB1
      search --no-floppy --fs-uuid --set=root D85B-0CB1
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
set timeout_style=menu
  • Need ro see output for sudo parted -l and for grep -A10 -i 'Windows' /boot/grub/grub.cfg. Feb 4, 2019 at 0:43
  • did you happen to change SATA mode in the BIOS, from RAID (or Intel RST) to AHCI...? If so, that could cause the problem you describe.
    – TonyB
    Feb 4, 2019 at 0:47
  • @PaulBenson added outputs to post Feb 4, 2019 at 0:58
  • @TonyB actually yes I did, i think that was to fix an issue during installing ubuntu from USB stick where it would not recognize my hard drive, i will change it back to RAID and see if it fixes anything Feb 4, 2019 at 0:59
  • Does your PC happen to have Intel Rapid Storage Technology installed on it? Perhaps Optane memory? I helped a friend install a dual boot on a system like that and there are specific steps you have to take to enable a dual boot environment... this link describes the steps.
    – TonyB
    Feb 4, 2019 at 1:04

4 Answers 4


I had a similar issue to what Maciej above said, except my windows partition was UEFI and my ubuntu kept installing in legacy, so I would then only be able to get into Windows by changing my BIOS settings. The issue was that my USB stick was legacy and didn't support UEFI, so the install would only run legacy. Once I created a new boot/install disk on a better USB I was able to get both to work on the same boot menu


This is just a speculation, but may help. Maybe GRUB is using old GPT boot, a.k.a. BIOS, a.k.a. Legacy mode, while Windows are EFI a.k.a. UEFI. So while in BIOS mode, there is no way to start EFI Windows.

You can go into BIOS and try to force EFI boot, or by setting "EFI only", or by disabling "Legacy mode", "BIOS mode" or whatever, depending on BIOS. Also disabling "Fast boot" and other possible "improvement" may sometimes help.

You can also first try to summon BIOS boot menu, sometimes by pressing F12, and check if it allows direct start of EFI Windows, without even booting GRUB.


Fixed issue with not being able to load into Windows from GRUB by switching back from AHCI mode to RAID mode in BIOS.


OK. The last option in grub.cfg, (menuentry 'Windows Boot Manager on /dev/nvme0n1p1) is the important one that boots into Windows. All the other Windows entries are superfluous.

There is one crucial line missing - set root='x0, gpt1'. For hard drives x=hd, but in your case it may not be hd for NVMes, but not certain of the notation as I don't use an M2 SSD. The first disk always has a '0' at the end, and in a 2 disk drive the 2nd disk has the notation '1'. So in my case I have hd0 referred to for my Windows disk, and hd1 for my Linux disk as I have 2 hard drives, one for each system. Whatever, that missing line defines where the esp is for Windows and should be 4th line down for the menu entry, so possibly something like 'set root='nvme0,gpt1', or it may well still be notated as set root='hd0,gpt1' despite what I've suggested. The easiest way to know is look in the file at the menu entry for Ubuntu and see how 'set root=...' is notated there for an NVMe. Personally I'd try using hd0 first.

There is a further issue that you may have damaged the system boot partition for Windows. If you boot from BIOS can you still boot into Windows as first boot entry?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.