8

I'm getting this error message:

"Incorrect permission on /usr/lib/policykit-1/polkit-agent-helper-1(need to setuid root)"

Due to this problem I can't download any app.

  • 1
    Did you do something to your system just before this started to happen? If you strred your system with a root stick, playing whack-a-mole with the aftereffects isn't worth the effort. – waltinator Feb 2 '19 at 21:42
11

This is the solution I came up with and tried, and it seemed to work, not sure why the permissions changed on this file though.

sudo chmod 5755 /usr/lib/policykit-1/polkit-agent-helper-1

I also saw a version that tried: sudo chmod +s ... but I didn't like the file permissions, so I opted to mirror the other permissions for the files in /usr/lib/policykit-1/

| improve this answer | |
  • that works, thank you! – Kamil Naja Nov 3 '19 at 13:46
  • 1
    Thanks, sudo chmod 5755 /usr/lib/policykit-1/polkit-agent-helper-1 is secure. It worked for me. – Aravind Nov 6 '19 at 18:15
  • 1
    Thanks alot, worked like expected! – BloodyLogic Mar 24 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.