1

I am trying to create a bootable USB. Currently on lsblk I have sdc -> sdc1, formatted to fat32.

I am trying now to save my iso with the following command:

sudo dd if=/dev/puppylinux.iso \ of=/dev/sdc bs=4M && sync status=progress

The error I am getting is:

dd: unrecognized operand ‘ of=/dev/sdc’

From all the searching I did, I can see that the of=...should be as I wrote it to be. What am I doing wrong?

1
  • 1. Please remove the backslash before of=... 2. status=... will not work where you put it. It should be before && or not at all – sudodus Feb 2 '19 at 16:11
2

The dd command that you tried has an unnecessary / character after if=/dev/puppylinux.iso which should be removed. sync is a separate command, so it goes after the && so that sync runs only if the first command ( dd ) ran.

The correct command is:

sudo dd if=/dev/puppylinux.iso of=/dev/sdc bs=4M status=progress && sync  
3
  • +1; This will work, but using dd like this is risky, because dd has no final checkpoint, so it is easy to write to and overwrite the wrong drive. I would recommend Ubuntu's Startup disk creator, Disks (alias gnome-disks) or mkusb. – sudodus Feb 2 '19 at 16:18
  • Startup Disk Creator is a great USB creator program which I prefer to use instead of dd. – karel Feb 2 '19 at 16:22
  • 1
    Worked like a charm. I just wanted to fiddle a bit with the dd command. Thanks! Won't let me upvote the answer because of low reputation. :( – Svetoslav Antonov Feb 2 '19 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.