5

I recently switched to Linux. Everything went fine, but when I installed the gnome-shell, it started to ignore clicks outside the focused window. I cannot click on another window to focus it or click on any gnome UI elements. The super key also does nothing. I installed gnome-tweaks and I use a user theme, but that shouldn't be the problem because the problem remained even when I had a fresh install. Also, sometimes when I reboot it works normally. But after another reboot, it comes back.

PS- I found a very temporary fix: If I move the focused (or sometimes other windows) it will start recognizing my keystrokes. On Firefox I need to move the window by the bar with open tabs, as I cannot move it with the title bar.

I read this thread by someone who had a very similar issue, but the solution did not work for me. I think it has to do something with NVidia drivers, because if I change them then the frequency of this happening changes.

Sorry if something is weirdly written. English is not my native language.

7
  • Hi, welcome to Linux! English shouldn't be a barrier in the way of solution as long as you can adequately explain your troubles. Cheerios! :) PS - Windows key is supposedly refered to as the Super Key. – lordparthurnaax Feb 2 '19 at 15:52
  • Thanks, I approved the edit. And changed the 'windows key' to super key. – bain Feb 2 '19 at 16:07
  • Did you try all the answers posted to the question you mentioned? For example are you in a Wayland session? What is the output of the following command in Terminal: echo $XDG_SESSION_TYPE? – pomsky Feb 2 '19 at 16:24
  • @pomsky The output of the command is x11. So I'm not in a Wayland session. I guess? EDIT 1 and 2: I'm dumb – bain Feb 2 '19 at 16:30
  • Also, yes I did try all the answers. The second one even booted me to a black screen. – bain Feb 2 '19 at 16:55
7

So after doing some more research, I stumbled upon a thread with the same question. It turned out to be a problem with my Mad Catz R.A.T. 3 mouse. I didn't realise that i didn't have any drivers for it. Here's how you can fix this issue.

Write this section to /etc/X11/xorg.conf:

Section "InputClass"    Identifier "Mouse Remap"
    MatchProduct "Madcatz Mad Catz R.A.T.3 Mouse"
    MatchDevicePath "/dev/input/event*"
    Option "ButtonMapping" "1 2 3 4 5 6 7 8 0 0 0 0 0 0 0 0 0 0 0"
EndSection

PS: Here's a link to ArchWiki. It has all the information you need to set up your mad catz mouse.

1
  • 1
    Please do not delete your question! Links to outside website may not work in the future, and you have attributed your answer to these outside sources and included the relevant bits to the answer that you have provided. – Charles Green Feb 3 '19 at 14:28
0

I had the same issue with my Kingsis Peripherals Evoluent VerticalMouse 4. Appending the following to the bottom of xorg.conf file fixed it for me. Thanks!

Section "InputClass"
    Identifier       "Mouse Remap"
    MatchDevicePath  "/dev/input/event*"
    MatchProduct     "Kingsis Peripherals Evoluent VerticalMouse 4"
    Option           "ButtonMapping"   "1 2 3 4 5 6 7 8 0 0 0 0 0 0 0 0 0"
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.