1

I'm running Ubuntu Studio 18.10 on a Dell Latitude. After a seemingly random amount of time (but at least 20 minutes... sometimes over an hour), my wifi stops, and is no longer present on the Network Manager panel. I need to reboot my PC to get it up again.

I'm getting wifi firmware errors (but, the wifi is working regardless - but I don't know for how long):

mike@hurricane:~$ dmesg | grep wifi
[   14.171159] iwlwifi 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[   14.171764] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
[   14.224862] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
[   14.738890] iwlwifi 0000:02:00.0: loaded firmware version 9.221.4.1 build 25532 op_mode iwldvm
[   15.212507] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   15.212509] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   15.212511] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   15.212514] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
[   17.521848] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
[   33.160746] iwlwifi 0000:02:00.0: Radio type=0x0-0x3-0x1
[   33.403828] iwlwifi 0000:02:00.0: Radio type=0x0-0x3-0x1

Info re. my computer:

mike@hurricane:~$ inxi
CPU: Dual Core Intel Core i5-2520M (-MT MCP-) 
speed/min/max: 3016/800/3200 MHz Kernel: 4.18.0-13-lowlatency x86_64 Up: 21m 
Mem: 1067.9/7853.4 MiB (13.6%) Storage: 298.09 GiB (61.4% used) Procs: 216 
Shell: bash 4.4.19 inxi: 3.0.24 

mike@hurricane:~$ inxi -M
Machine:
  Type: Laptop System: Dell product: Latitude E6420 v: 01 
  serial: <root required> 
  Mobo: Dell model: 0K0DNP v: A02 serial: <root required> BIOS: Dell v: A08 
  date: 10/18/2011 

mike@hurricane:~$ uname -a
Linux hurricane 4.18.0-13-lowlatency #14-Ubuntu SMP PREEMPT Wed Dec 5 12:12:14 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

...and the networking hardware:

mike@hurricane:~$ inxi -n
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e 
  IF: eno1 state: down mac: d4:be:d9:19:89:0f 
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi 
  IF: wlp2s0 state: up mac: 24:77:03:39:c1:04 
  IF-ID-1: wwp0s29u1u6i6 state: down mac: 02:80:37:ec:02:00 

mike@hurricane:~$ lspci -v | grep -iE -5 'wifi'
02:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
    Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
    Flags: bus master, fast devsel, latency 0, IRQ 29
    Memory at e2d00000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: <access denied>
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

0a:00.0 SD Host controller: O2 Micro, Inc. OZ600FJ0/OZ900FJ0/OZ600FJS SD/MMC Card Reader Controller (rev 05) (prog-if 01)
    Subsystem: Dell OZ600FJ0/OZ900FJ0/OZ600FJS SD/MMC Card Reader Controller
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at e2c20000 (32-bit, non-prefetchable) [size=512]

I assume that these firmware errors are part of the problem - but I really don't know.

I would appreciate any possible assistance. I have tried several Linux distros on this laptop (including Opensuse Leap, MX-17.1, and Netrunner), but have never come across this before. I have reinstalled Ubuntu Studio (both 18.04 and 18.10) but that makes no difference.

Thank you.

  • I have just tried the following: - edit the file: /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf - change the value wifi.powersave = 3 to wifi.powersave = 2 Then reboot and do this: echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlwifi11n.conf This, I am told, will disable the power saving on the wifi modem. I'll give Netflix a try tonight and see how well that works! Source: linuxquestions.org/questions/linux-networking-3/… – stroudmw Feb 2 '19 at 7:59
1

I seem to have found a solution:

edit the file: /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf - change the value wifi.powersave = 3 to wifi.powersave = 2 - Then reboot and do this:

echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlwifi11n.conf

This will stop the wifi's "powersave" feature. I have tested this by going on an extended Netflix binge, and haven't had any more problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.