I use Firefox Quantum 65.0 in Ubuntu 18.10.

I recently installed TeXmaker. When I tried to open help files, I got following error from Firefox.

enter image description here

File path is:

enter image description here

I am able to open the same html file with text editor.

By the way, Firefox could open html files from /home folder. However it could not access html files of /usr...

Please suggest about how I can open html files from /usr folder in Firefox.

  • 1
    How did you installed Firefox? Is it a Snap application? Please add outputs of snap list | grep -i firefox, apt-cache policy firefox, which firefox, firefox --version to the question. – N0rbert Feb 2 '19 at 9:26

It seems that you have installed Firefox as a Snap. It is normal that it can't access the folders inside root-filesystem:

$ snap interfaces | grep firefox
:avahi-observe             firefox
:browser-support           firefox:browser-sandbox
:camera                    firefox
:cups-control              firefox
:desktop                   firefox
:desktop-legacy            firefox
:gsettings                 firefox
:home                      firefox
:network                   firefox,pulsemixer
:opengl                    firefox
:pulseaudio                firefox,pulsemixer
:screen-inhibit-control    firefox
:unity7                    firefox
:upower-observe            firefox
:x11                       firefox,pulsemixer
-                          firefox:network-observe
-                          firefox:removable-media

Consider to remove Snap with

sudo snap remove firefox

and install APT version

sudo apt install firefox

and visit local help page.

  • Is it just me or it's very dumb that 1/ Firefox snap version cannot open any file outside /home, thus preventing to read this kind of doc, AND to link any protocol handler to an app in /usr for example ; and 2/ that the snap version is the one appearing first in Ubuntu Software? Way to repell newcomers, I'm baffled. – pHneutre Mar 6 '20 at 15:28

You seem to have an extra forward-slash in your file path.

Use file:///usr/share/texmaker/usermanual_en.html, it should work fine.

Edit- Just in case, here's the online help repo of TexMaker http://mcs.une.edu.au/doc/texmaker/usermanual_en.html

  • I tried your hint. It did not work. – Felix Solomon Feb 2 '19 at 7:00
  • 1
    Ok try this. Paste this to your firefox search bar file:///usr/share/. It should show you the directory tree. If it exists, then go to texmaker directory from there and open usermanual_en.html. Let me know if these dont work. – lordparthurnaax Feb 2 '19 at 7:06
  • When I entered "file:///usr/share/", I got error "Access to the file was denied". – Felix Solomon Feb 2 '19 at 7:11
  • Go to terminal and open firefox with sudo, as sudo firefox. Then it should work. – lordparthurnaax Feb 2 '19 at 7:13
  • 6
    Running a web browser as root user or sudo is not a good idea. If that's considered a "solution", then something else is probably wrong (there was). – userSeventeen Feb 2 '19 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.