0

I am trying to install some packages but i receive message error:

E: Unable to locate package libodbcinstq4–1 
E: Unable to locate package libodbcinstq4–1:i386
E: Unable to locate package libzthread-2.3–2
E: Couldn't find any package by glob 'libzthread-2.3–2'
E: Couldn't find any package by regex 'libzthread-2.3–2'

As repository, I added:

echo ‘deb http://cz.archive.ubuntu.com/ubuntu precise main universe’ >> /etc/apt/sources.list.d/extra.list

with the response of N0rbert, I have the following output:

libodbcinstq4-1 is already the newest version (2.3.0-4).
libodbcinstq4-1:i386 is already the newest version (2.3.0-4).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libodbcinstq4-1:i386 : Depends: odbcinst1debian2:i386 (>= 2.2.14p2) but it is not going to be installed
 libqtcore4 : Breaks: libqtcore4:i386 (!= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed
 libqtcore4:i386 : Breaks: libqtcore4 (!= 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1) but 4:4.8.7+dfsg-5ubuntu2 is to be installed
 libqtgui4:i386 : Depends: libqt4-declarative:i386 (= 4:4.8.7+dfsg-5ubuntu2) but it is not going to be installed
                  Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed
                  Depends: libtiff5:i386 (>= 4.0.3) but it is not going to be installed
                  Depends: libxext6:i386 but it is not going to be installed
                  Depends: libxi6:i386 (>= 2:1.2.99.4) but it is not going to be installed
                  Depends: libxrender1:i386 but it is not going to be installed
                  Recommends: libcups2:i386 but it is not going to be installed
                  Recommends: qt-at-spi:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried apt-get -f install to correct the problem, but among the results I got this error message:

Errors were encountered while processing: /var/cache/apt/archives/libqtcore4_4%3a4.8.7+dfsg-5ubuntu2_i386.deb 
E: Sub-process /usr/bin/dpkg returned an error code (1)
13
  • What is your Ubuntu version? Ubuntu 12.04 LTS (precise) is EOL.
    – N0rbert
    Feb 1, 2019 at 13:14
  • I am using Ubuntu 16.04
    – mikcutu
    Feb 1, 2019 at 13:17
  • Then you should enable all 16.04 LTS (xenial) repositories and follow my answer.
    – N0rbert
    Feb 1, 2019 at 13:18
  • how can I enable all Xenial repositories?
    – mikcutu
    Feb 1, 2019 at 13:19
  • I added the output of installation of the 3 packages
    – mikcutu
    Feb 1, 2019 at 13:23

1 Answer 1

3

You should not use long dash instead of minus sign (-). Replace all to - and retry.

sudo add-apt-repository universe
sudo apt-get install libodbcinstq4-1 libodbcinstq4-1:i386 libzthread-2.3-2

Not the answer you're looking for? Browse other questions tagged or ask your own question.