I need to change my background wallpaper through terminal. So I entered this line in terminal:

gsettings get org.gnome.desktop.background picture-uri 'file:///appdev/wallpaper.jpg'

The output is:

Usage: gsettings [--schemadir SCHEMADIR] get SCHEMA[:PATH] KEY
Get the value of KEY
Arguments: SCHEMADIR A directory to search for additional schemas
SCHEMA The name of the schema PATH The path, for relocatable schemas KEY The key within the schema

Also using set as shown below didn't work:

gsettings set org.gnome.desktop.background picture-uri 'file:///appdev/wallpaper.jpg'

How do I fix this issue?

  • 2
    gsettings get gives you the current value of a setting, gsettings set changes it. – Jos Feb 1 at 9:20
  • 1
    No it doesn't worked@Jos – Naveen Feb 1 at 9:24
  • Then at least edit your question with the output of gsettings set. – Jos Feb 1 at 9:25
  • 1
    There doesn't came any out put for set@Jos anyway I have edited. – Naveen Feb 1 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.