0

I have been attempting to install net-responsibility on Bionic Beaver, and have run into alot of issues. First I tried: (per the website)

sudo add-apt-repository ppa:roggan87/nr

However I get the following error:

E: The repository 'http://ppa.launchpad.net/roggan87/nr/ubuntu bionic
Release' does not have a Release file. N: Updating from such a repository
can't be done securely, and is therefore disabled by default.

So I try installing manually by compiling the source code, I first install poco-1.9.1 library. Works fine. But after compiling and installing net-responsibilities' make file, I get an error that says the common.h file within the poco library is missing. After some digging I see that version 1.9.1 does not have common.h, but version 1.4.1 does, so I try and install that (after removing 1.9.1 with checkinstall...hopefully I did that correctly) but then I get the following error: (while trying to install poco 1.4.1)

src/CipherImpl.cpp:99:21: error: field ‘_ctx’ has incomplete type ‘EVP_CIPHER_CTX {aka evp_cipher_ctx_st}’    EVP_CIPHER_CTX    _ctx;
                     ^~~~ In file included from /usr/include/openssl/evp.h:14:0,
                 from include/Poco/Crypto/CipherImpl.h:47,
                 from src/CipherImpl.cpp:37: /usr/include/openssl/ossl_typ.h:90:16: note: forward declaration of ‘EVP_CIPHER_CTX {aka struct evp_cipher_ctx_st}’  typedef struct evp_cipher_ctx_st EVP_CIPHER_CTX;
                ^~~~~~~~~~~~~~~~~ /home/daniel/Downloads/poco-poco-1.4.1/build/rules/compile:53: recipe for target '/home/daniel/Downloads/poco-poco-1.4.1/Crypto/obj/Linux/x86_64/debug_shared/CipherImpl.o' failed make[1]: *** [/home/daniel/Downloads/poco-poco-1.4.1/Crypto/obj/Linux/x86_64/debug_shared/CipherImpl.o] Error 1 make[1]: Leaving directory '/home/daniel/Downloads/poco-poco-1.4.1/Crypto'

So, from here I am not sure what to do. I am pretty new to Ubuntu, so i could be missing the obvious. I know that this program is VERY outdated to try and run it on the newest version of Ubuntu, so let me know If am I embarking on a fools errand.

UPDATE: After editing the apt-get files in ect/apt/sources.list.d/ the ppa or repository (not sure what to call them) did update successfully, however when I tried to install I received the following error:

net-responsibility: symbol lookup error: /usr/lib/libPocoFoundation.so.16: undefined symbol: _pcre_ucd_stage1 dpkg: error processing package net-responsibility (--configure): installed net-responsibility package post-installation script subprocess returned error exit status 1 Processing triggers for libc-bin (2.27-3ubuntu1) ... Errors were encountered while processing: net-responsibility E: Sub-process /usr/bin/dpkg returned an error code (1)

After attempting to installing via .deb I got the following error:

This package is uninstallable A later version is already installed

Running the check script indicates hat NR is not running so I am guessing installation failed completely. From what I can tell the issues lies in the pocolib, so there way to delete it completely and reinstall?

UPDATE #2: Found this great resource, for anyone else attempting to install NR.

Thanks!

1

It appears the author of that PPA hasn't updated it in a few years, so it doesn't have a release for newer versions of Ubuntu.

If you want to go the PPA route (which is easiest) you can simply modify it to use the xenial PPA instead of bionic by modifying the associated file in /etc/apt.sources.d/roggan87-nr.list changing bionic to say xenial instead. Then do an apt update and it should find the packages and install them. Since it's an older PPA it may complain if the package dependencies have changed drastically over the years, but in this case they likely haven't.

It's also worth noting that you don't have to compile from source to use net-responsibility as they make .deb packages available here. In that case you can install the .deb file using gdebi.

Regarding why the compile is failing it appears that in OpenSSL had changes around 1.0.2 (info) relating to how the development libraries were used and this software wasn't updated. It's not a problem for binary packages / already built packages since it still can use later OpenSSL libraries, it's just a problem the developers of net-responsibility haven't updated.

2
  • Alright, thank you so much for your answer! Im going to try these out and get back to you! – djjohnsongeek Feb 2 '19 at 3:06
  • Gave it a shot, got one step closer, but still receiving errors. I updated the question. – djjohnsongeek Feb 2 '19 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.