13

I’m trying to install Windows 10 into virtualbox on Ubuntu 18, however when trying to first boot up it says Press F12 to select boot device and then switches to this screen and flashes a green and blue background pic settings1 settings2 settings3 settings4 I’ve tried enabling and disabling 3D/2D acceleration. enter image description here Why isn’t it working?

16
  • Could you please elaborate a bit on what you are trying to do? Do you have an iso image of Windows 10? How did you configure your vbox?
    – FloT
    Jan 31, 2019 at 23:03
  • Yes I do. And I configured it with a dynamic drive. I gave it 1/2 my ram, 2 of 4 CPUs.
    – Mark Deven
    Jan 31, 2019 at 23:10
  • Did you try to press F12 at virtual machine startup to see the list of available drives? Did you try to choose W10 iso manually? Would you please post pictures of virtual machine system, display and storage?
    – FloT
    Jan 31, 2019 at 23:16
  • Yes. The only one with anything on it is the disc drive. And sure
    – Mark Deven
    Jan 31, 2019 at 23:17
  • Just in case - Ubuntu has a nice screenshot tool ;)
    – FloT
    Jan 31, 2019 at 23:19

8 Answers 8

10

I just ran into this checkerboard issue while trying to setup a Windows 10 Enterprise (version 2004) VM with VirtualBox 6.1.

When creating the virtual machine, VirtualBox incorrectly detected the VM as a Windows NT 4 install instead of a Windows 10 install resulting in the checkered screen on boot. To fix this, go under Settings -> General -> Basic and verify the version is correctly set to Windows 10.

Boots properly into the installer after changing this.

3
  • 4
    I had a similar issue. In my case, the VM had reset itself to "Windows 10 32-bit", while I was trying to install a 64-bit Windows image. The weird thing was that I did select 64-bit in the VM creation wizard!
    – dovetalk
    Jun 22, 2020 at 17:22
  • I had the same issue as @dovetalk
    – Dan
    Jul 19, 2020 at 19:37
  • I had a similar experience and I'm also 100% sure I had selected the 64 bit version. However, setting it back to 64 bit did not actually help. Deleting and recreating a VM worked, however.
    – YoungFrog
    Jan 25, 2021 at 17:54
7

Had a similar issue. Fixed it by changing the version from 32bit to 64bit.

Settings>>Basic>>Version

3

I had this same problem and finally solved it by starting from the beginning. I deleted the Windows 10 .iso and re-downloaded it. I guess the one I was trying to use was corrupted. Then, I removed the VM that I previously created and deleted all its files.

You can get the iso here: https://www.microsoft.com/en-in/software-download/windows10ISO

I assume you know the rest; but, if not, I found this guide helpful: https://itsfoss.com/install-windows-10-virtualbox-linux/

3
  • I attempted this and it did in fact work. Computers are weird.
    – Mark Deven
    Oct 25, 2019 at 2:27
  • 1
    I did a checksum ("Verify your download"), and it matched; so I kept the fil. Re-creating a new VM still worked for me, but I made sure the name had no funky characters, and gave it 4 G of RAM instead of 2 G. "computers are weird" is a good summary of this experience.
    – YoungFrog
    Jan 25, 2021 at 17:52
  • Indeed, the file may have been corrupted. There are tools to verify this (sha256 checksum), before doing the (gigantic) download again; they're even advocated on the download site.
    – xtofl
    Jun 12, 2021 at 9:30
0

The solution for me was that, under the system tab, I needed to enable i/o APIC.

I wish I could upvote this, because, while I'm sure some of the other solutions worked for others, I'm guessing that this will be the problem for 90% of the folks that visit this page.

0

I had a similar issue, but ultimately not the same cause.

Ultimately it required:

  • More than default RAM/CPU
  • VRam set to at least 128 and be set to vboxsvga

Below is the snippet of packer hcl2 I was writing that I was able to use to get things working. Hopefully this helps the next person running into this issue to get off the ground.

source "virtualbox-iso" "local" {
  # Find this via: `VBoxManage list ostypes | less`
  guest_os_type = "Windows10_64"
  iso_url = "https://software-download.microsoft.com/download/pr/19041.264.200511-0456.vb_release_svc_refresh_CLIENTENTERPRISEEVAL_OEMRET_x64FRE_en-us.iso"
  iso_checksum = "sha256:f1a4f2176259167cd2c8bf83f3f5a4039753b6cc28c35ac624da95a36e9620fc"

  shutdown_command = "shutdown /s /t 10 /f /d p:4:1 /c Packer_Provisioning_Shutdown"

  floppy_files = [
    "Autounattend.xml",
  ]

  cpus = 4
  memory = 4096
  disk_size = 163840
  
  vboxmanage= [
    ["modifyvm", "{{.Name}}", "--vram", "128"],
    ["modifyvm", "{{.Name}}", "--graphicscontroller", "vboxsvga"],
  ]

  # Communicator settings omitted, since they are not relevant to this problem
}
0

I was having the same issue. I just deleted the VM and created it again. No need for downloading the image again. Actually I checked the ISO's SHA256 hash and it was just fine.

0

Same problem here. After hours reading forums, I discovered the cause root was Intel Power Gadget. After removing, all worked fine.

0
0

I downloaded Windows 32-bit for VBox and selected Window 10 32-bit. However got same issue. It's fixed by selecting 64-bit

2
  • Hello and Welcome to Ask Ubuntu. I do recommend that you read through the existing answers before adding a new one. This looks to be the exact same as this existing answer. Thanks! May 9 at 21:43
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 10 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.