4

Installed PHPStorm via snap.

sudo snap install phpstorm --classic

1) When I try to run it from launcher, it just closes after a few seconds.

2) When I try to run it from terminal, I get: "/ has 'other' write 40777."

My system is Ubuntu Mate 18.04.1 and below info about snap

snap --version
snap 2.37
snapd 2.37
series 16
ubuntu 18.04
kernel 4.15.0-45-generic

I've tried following suggestion but it didn't worked

https://stackoverflow.com/questions/51027327/ubuntu-18-04-var-lib-snapd-has-other-write-40777

Any ideas how to solve this issue? The same installation went without an issue on my main desktop with Ubuntu 18.04.1.

7

I did massive mistake. I've started to investigate and I found out that for some reason my root directory / had 777 permissions! Thankfully I quickly fixed it by doing

sudo chmod 755 /

After that fix PHPStorm launched without an issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.