4

I am using a barebones Ubuntu 16.04 in VirtualBox, macOS host. Up to VirtualBox 6.0.0, everything was working fine. But with VirtualBox 6.0.2, 6.0.4 and 6.0.6, Unity crashes on startup. In ~/.xession-errors I see lines similar to

upstart: unity7 main process (3256) killed by SEGV signal
upstart: unity7 main process ended, respawning
upstart: unity7 main process (3290) killed by SEGV signal
upstart: unity7 main process ended, respawning
upstart: unity7 main process (3324) killed by SEGV signal
upstart: unity7 main process ended, respawning
upstart: unity7 main process (3358) killed by SEGV signal

Is anyone else experiencing this, or is it specific to my setup? Is there any other solution than downgrading to VirtualBox 6.0.0?

Turning off 3D acceleration in VirtualBox fixes the problem, but also makes Ubuntu unusably slow.

2

The workaround from https://www.virtualbox.org/ticket/18324 worked for me, after opening up the terminal in a (ctrl+alt+F1) and logging in:

sudo apt install patchelf  # For Debian/Ubuntu etc.
sudo patchelf --add-needed libcrypt.so.1 /opt/VBoxGuestAdditions-6.0.6/lib/VBoxOGLcrutil.so
| improve this answer | |
  • This helped me to fix the issue where lightdm used to crash on login to Ubuntu Guest OS on MacOS host. I am currently using VirtualBox version 6.0.8 and VirtualBox Guest Additions version 6.0.8. – Raman Jun 23 '19 at 3:02
2

This bug report should enlighten you. There's a bugfix available via guest additions beta version: https://www.virtualbox.org/ticket/18325

If the direct link to the beta ISO mentioned there does not work - there's a link on "test builds", just look there for the latest version: https://virtualbox.org/wiki/Testbuilds

UPDATE: As the - currently - only working TestBuild was removed I uploaded the working Guest Additions to the following link (available until 04/2020): https://file.town/download/fj25drxul6zxnl88pz398pmwt

Background: It seems like the problem (library linking error) regressed in current Guest Addition Releases (at least <= 6.0.6): https://www.virtualbox.org/ticket/18324

So we're still waiting for the real fix...

UPDATE 2: With VirtualBox 6.0.10 released, the problems are gone, as also mentioned within the ticket description. Head to the following page to download the latest version and also install latest Guest Additions to Host(s): https://www.virtualbox.org/wiki/Downloads

| improve this answer | |
  • 1
    Sadly the guest additions link references there is no longer working, so I can't try it. Hopefully this will be in 6.0.6 (or whichever version is next). – Szabolcs Feb 25 '19 at 18:37
  • I downloaded test build 129045 for macOS, and installed the guest additions contained within ("6.0.5"). Unfortunately, the problem is still present in this version. – Szabolcs Feb 26 '19 at 21:04
  • I also tried the guest additions test build revision 129041. It also does not work. – Szabolcs Feb 26 '19 at 21:07
  • Do you know where one can get a test version that includes this fix? 129665 does not. – Szabolcs Mar 30 '19 at 9:36
  • 1
    I confirm that the version you uploaded works fine. I tried in 6.0.0 and 6.0.6. – Szabolcs May 4 '19 at 18:48
1

I had same issue. This one from Development snapshots section worked in my case. https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_6.0.97-129282.iso

| improve this answer | |
  • I did not have the time to test at that time, and with 129665 it does not work. 129282 is no longer available. – Szabolcs Mar 30 '19 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.