3

Everything worked fine until yesterday :) I use a mini-DP to connect to my screen for over a year now. Now, when I connect the cable it recognizes it (so I see the Ubuntu background in the screen and can work in my laptop) but when I close the lid or set the monitor as the main screen (so as to work only from the monitor screen as I have been doing), the whole system freezes. Removing the cable does nothing. Only hard reboot (pressing continuously the power button) brings it up.

Kernel: 4.15.0-44-generic, on 18.04.1 LTS (Bionic).

I cannot get anything from dmesg because of the freeze, but some errors from /var/log/syslog that maybe can help:

kernel: [  495.245250] ACPI Error: Method parse/execution failed \_GPE.XTBT, AE_ALREADY_EXISTS (20170831/psparse-550)
...
kernel: [  495.308520] pci 0000:03:00.0: BAR 13: failed to assign [io  size 0x2000]
...
gsd-color[1425]: no xrandr-Dell Inc.-DELL U2417H-5K9YD7AE224L device found: Failed to find output xrandr-Dell Inc.-DELL U2417H-5K9YD7AE224L
...
/usr/lib/gdm3/gdm-x-session[1974]: Errors from xkbcomp are not fatal to the X server
...
systemd-udevd[4191]: Process '/usr/sbin/alsactl -E HOME=/run/alsa restore 1' failed with exit code 99.
...
gnome-shell[1216]: Failed to apply DRM plane transform 0: Permission denied
gnome-shell[1216]: Failed to read EDID from 'eDP-1': No such file or directory
gnome-shell[1216]: message repeated 3 times: [ Failed to read EDID from 'eDP-1': No such file or directory]
gsd-color[1425]: failed to set screen _ICC_PROFILE: Failed to open file â<80><9c>/home/john/.local/share/icc/edid-18e261c7e650a8a483510701873ac4e2.iccâ<80><9d>: Permission denied

Anyone else with the same problem? What do I have to do if this is a general issue to let Ubuntu developers know about it?

1

So, the issue is in the 4.15.0-44-generic kernel and has been solved in the 4.15.0-45-generic. To manually update, run:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

And that fixes it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.