I have a very strange problem. Up until now my Dell 7730 laptop with Intel graphics has been working fine with Kubuntu 18.04.1. Today I created /etc/rc.local and made it executable. The only command was "mount -a" followed by "exit 0" to mount an nfs share after boot. I had "#!/bin/sh -e" at the top as usual.

I then rebooted, the splash logo was seen on my laptop and two DisplayPort monitors (connected via docking station) as usual after which I entered my luks password to allow access to my encrypted disks. After that, normally a few dmesg messages show up briefly just before the login screen appears on all three displays (laptop and two monitors) after which I login and all is well (normally).

After adding /etc/rc.local and rebooting though, after the normal dmesg messages appeared on all three screens, two of them went blank and the messages were just sitting there on the remaining external monitor and the login screen did not appear. Note that the messages are related to unsigned virtualbox drivers, are "normal" i.e. always there and aren't relevant I believe.

If I then power cycle without the monitors connected, the boot process works fine, the login screen appears on the laptop display and I can login as normal.

If I then connect the external monitors then they are also detected fine and work normally! This is the workaround so far.

It seems that for some reason there is a graphics problem with the external monitors connected that leads to the boot hanging just before the login screen (which never appears)?

What I've tried so far without success:

1) Deleting /etc/rc.local which was the only change I made before this happened and rebooting/power cycling.

2) sudo apt update; sudo apt upgrade; (Reboot)

Note that the problem started only after creating and making /etc/rc.local executable. ** No other changes or updates/upgrades were made before this problem started. ** I was running 4.15.0-43-generic when the problem started and now 4.15.0-44-generic which I upgraded to seeing if the commands immediately above would solve the problem.

3) apt install --reinstall lightdm; apt install --reinstall kubuntu-desktop; apt install --reinstall sddm; (Reboot)

Any ideas how to fix this? Reconfiguring sddm? Reinstalling the intel packages below?

More info. below.

Many thanks for your help!

uname -a
Linux myhost 4.15.0-44-generic #47-Ubuntu SMP Mon Jan 14 11:26:59 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

dpkg -l | grep intel
ii intel-microcode 3.20180807a.0ubuntu0.18.04.1 amd64 Processor microcode firmware for Intel CPUs
ii libdrm-intel1:amd64 2.4.91-2 amd64 Userspace interface to intel-specific kernel DRM services -- runtime
ii xserver-xorg-video-intel 2:2.99.917+git20171229-1 amd64 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-intel-hwe-16.04 3:14.1 amd64 Transitional package for xserver-xorg-video-intel-hwe-16.04

sudo lshw -class video
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:178 memory:9f000000-9fffffff memory:60000000-6fffffff ioport:3000(size=64) memory:c0000-dffff

I solved this by rolling back my kernel Version using this answer. Afterwards I deleted the newest kernel version just to be safe. So the problem must be related to the kernel version 4.15.0-44-generic. I'm now running on 4.15.0-43-generic.

  • Thanks for the suggestion but unfortunately the problem was already present when using 4.15.0-43-generic. I ran "apt upgrade" in case it would solve the problem (which it didn't). – Dave Jan 31 '19 at 12:58

A subsequent install/upgrade via the gui updater where the packages below were installed/upgraded solved the problem. No idea which one solved it of course...

Install: libwayland-egl1:amd64 (1.16.0-1ubuntu1.1~18.04.1, automatic), libllvm7:amd64 (1:7-3~ubuntu0.18.04.1, automatic), linux-headers-4.15.0-45:amd64 (4.15.0-45.48, automatic), linux-modules-extra-4.15.0-45-generic:amd64 (4.15.0-45.48, automatic), linux-modules-4.15.0-45-generic:amd64 (4.15.0-45.48, automatic), linux-headers-4.15.0-45-generic:amd64 (4.15.0-45.48, automatic), linux-image-4.15.0-45-generic:amd64 (4.15.0-45.48, automatic) Upgrade: linux-headers-generic:amd64 (,, libdrm-nouveau2:amd64 (2.4.91-2, 2.4.95-1~18.04.1), linux-libc-dev:amd64 (4.15.0-44.47, 4.15.0-45.48), libapt-inst2.0:amd64 (1.6.6ubuntu0.1, 1.6.8), openjdk-8-jre:amd64 (8u191-b12-0ubuntu0.18.04.1, 8u191-b12-2ubuntu0.18.04.1), libvncclient1:amd64 (0.9.11+dfsg-1ubuntu1, 0.9.11+dfsg-1ubuntu1.1), libegl-mesa0:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libcairo-gobject2:amd64 (1.15.10-2, 1.15.10-2ubuntu0.1), grub-common:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), linux-image-generic:amd64 (,, apt:amd64 (1.6.6ubuntu0.1, 1.6.8), libavahi-glib1:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libkmod2:amd64 (24-1ubuntu3.1, 24-1ubuntu3.2), libglapi-mesa:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), snapd:amd64 (2.34.2+18.04, 2.37.1+18.04), linux-signed-generic-hwe-16.04:amd64 (,, linux-generic-hwe-16.04:amd64 (,, libavahi-common-data:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libavahi-common3:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libxatracker2:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), grub2-common:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), libegl1-mesa:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), ubuntu-release-upgrader-qt:amd64 (1:18.04.29, 1:18.04.30), libapt-pkg5.0:amd64 (1.6.6ubuntu0.1, 1.6.8), linux-signed-generic:amd64 (,, kmod:amd64 (24-1ubuntu3.1, 24-1ubuntu3.2), libvncserver1:amd64 (0.9.11+dfsg-1ubuntu1, 0.9.11+dfsg-1ubuntu1.1), libgbm1:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libwayland-client0:amd64 (1.14.0-2, 1.16.0-1ubuntu1.1~18.04.1), libdrm-amdgpu1:amd64 (2.4.91-2, 2.4.95-1~18.04.1), grub-efi-amd64-bin:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), python3-distupgrade:amd64 (1:18.04.29, 1:18.04.30), python3-update-manager:amd64 (1:, 1:, ubuntu-release-upgrader-core:amd64 (1:18.04.29, 1:18.04.30), avahi-daemon:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), tar:amd64 (1.29b-2, 1.29b-2ubuntu0.1), firefox-locale-en:amd64 (64.0+build3-0ubuntu0.18.04.1, 65.0+build2-0ubuntu0.18.04.1), libavahi-core7:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), libwayland-egl1-mesa:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libdrm2:amd64 (2.4.91-2, 2.4.95-1~18.04.1), libavahi-gobject0:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), apt-utils:amd64 (1.6.6ubuntu0.1, 1.6.8), libgl1-mesa-dri:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), grub-efi-amd64:amd64 (2.02-2ubuntu8.9, 2.02-2ubuntu8.10), libosmesa6:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), avahi-autoipd:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), openjdk-8-jre-headless:amd64 (8u191-b12-0ubuntu0.18.04.1, 8u191-b12-2ubuntu0.18.04.1), thermald:amd64 (1.7.0-5ubuntu1, 1.7.0-5ubuntu2), libgl1-mesa-glx:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), grub-efi-amd64-signed:amd64 (1.93.10+2.02-2ubuntu8.9, 1.93.11+2.02-2ubuntu8.10), libdrm-intel1:amd64 (2.4.91-2, 2.4.95-1~18.04.1), firefox:amd64 (64.0+build3-0ubuntu0.18.04.1, 65.0+build2-0ubuntu0.18.04.1), avahi-utils:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), linux-headers-generic-hwe-16.04:amd64 (,, apt-transport-https:amd64 (1.6.6ubuntu0.1, 1.6.8), libdrm-radeon1:amd64 (2.4.91-2, 2.4.95-1~18.04.1), mesa-vdpau-drivers:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libcairo2:amd64 (1.15.10-2, 1.15.10-2ubuntu0.1), libavahi-client3:amd64 (0.7-3.1ubuntu1.1, 0.7-3.1ubuntu1.2), linux-generic:amd64 (,, libwayland-server0:amd64 (1.14.0-2, 1.16.0-1ubuntu1.1~18.04.1), mesa-va-drivers:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libglx-mesa0:amd64 (18.0.5-0ubuntu0~18.04.1, 18.2.2-0ubuntu1~18.04.1), libdrm-common:amd64 (2.4.91-2, 2.4.95-1~18.04.1), libwayland-cursor0:amd64 (1.14.0-2, 1.16.0-1ubuntu1.1~18.04.1) End-Date: 2019-02-01 12:13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.