Not a copy of Apache2 install Error . apache2-bin , not the same error and "ok, I solved it" comment by OP...

I'm trying to install apache2 in order to install redmine on my Lubuntu 18.04.1 server.

When installing apache2, I have

Les paquets suivants contiennent des dépendances non satisfaites :
 apache2 : Dépend: apache2-bin (= 2.4.18-2ubuntu3.9) mais 2.4.29-1ubuntu4.5 
devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode 
« garder en l'état ».

English :

The following packages contain unsatisfactory dependencies :
 apache2 : depends : apache2-bin... but 2.4.29-1ubuntu4.5 must be installed
E: unable to correct, packages are in mode "keep state"

If I have to install 2.4.29-1ubuntu4.5 then OK but how ?

I have a LTS version of Lubuntu which was release-upgraded a few days ago :

> lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:        18.04
Codename:       bionic

dist-upgrade does nothing at all...

  • is there an "old" version of apache2-bin to solve this problem?
  • how must be installed this lubuntu4.5 thing?

Thank you!

@Organic Marble: here's the output, roughly copied from my phone's ssh app so I hope there's no typo

> sudo apt policy apache2
    Installed : (none)
    Candidate : 2.4.18-2ubuntu3.9
Version table:
      2.4.18-2ubuntu3.9 500
           500 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
      2.4.18-2ubuntu3.8 500
           500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
      2.4.18-2ubuntu3 500
           500 http://fr.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
  • 1
    Please edit your question to include the output of apt policy apache2 so we can see what version you are trying to install. – Organic Marble Jan 31 at 2:18
  • I've edited the question – Goufalite Jan 31 at 7:34
  • You still have some Xenial (16.04) repositories; you should update them to the Bionic (18.04) ones. – fkraiem Jan 31 at 13:25
  • @fkraiem do you have a command for this ? Or how is it done ? – Goufalite Jan 31 at 13:34
  • Just edit your sources.list, or whatever you use to manage your repositories... – fkraiem Jan 31 at 13:46

Your sources.list is problematic, it refers to xenial repos although you have a bionic install. Here is a sample bionic sources.list. I don't enable the source code repos and your country may vary as well. I removed all the comments.

deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
  • 1
    Changed all the xenial to bionic and now apache2 installs OK. Thank you! Any idea why it wasn't changed although the release upgrade ? – Goufalite Jan 31 at 19:16
  • Unfortunately I have no idea. I've always just done clean installs instead of upgrades. I am glad you got it working! – Organic Marble Jan 31 at 19:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.