0

Newbie Ubuntu user here, I'm trying to connect wirelessly using netplan, but for the life of me can't work out why it's not working, I have no problem connecting through Ethernet.

I'm on a newly build, dual boot PC running Ubuntu server 18.04 alongside Windows 10, and using "Intel Corporation Wireless 8260 (rev 3a)" card. All drivers etc are up to date.

Here is the netplan config file, I initially intended to setup a static IP, but since wifi wasn't working I decided to stick with dhcp for now:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp24s0:
      dhcp4: true
      dhcp6: true
      addresses: [192.168.1.222/24]
      gateway4: 192.168.1.1
      nameservers:
        addresses: [8.8.8.8,8.8.4.4]
  wifis:
    wlp26s0:
      dhcp4: true
      dhcp6: true
      addresses: []
      access-points:
        "DBEB Hyperoptic 1Gbps Broadband":
          password: "..."

Apologies, I only have the output of the commands to hand, not the exact command ran.

Rfkill output showing card isn't blocked:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
7: phy6: Wireless LAN
    Soft blocked: no
    Hard blocked: no

iwconfig | grep wlp26s0 (Shows access point not associated)

wlp26s0   IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Netplan debug apply:

** (generate:2452): DEBUG: 21:20:56.349: Processing input file //etc/netplan/01-netcfg.yaml..
** (generate:2452): DEBUG: 21:20:56.349: starting new processing pass
** (generate:2452): DEBUG: 21:20:56.349: wlp26s0: adding wifi AP 'DBEB Hyperoptic 1Gbps Broadband'
** (generate:2452): DEBUG: 21:20:56.349: enp24s0: setting default backend to 1
** (generate:2452): DEBUG: 21:20:56.349: wlp26s0: setting default backend to 1
** (generate:2452): DEBUG: 21:20:56.349: Generating output files..
** (generate:2452): DEBUG: 21:20:56.349: NetworkManager: definition enp24s0 is not for us (backend 1)
** (generate:2452): DEBUG: 21:20:56.349: wlp26s0: Creating wpa_supplicant configuration file run/netplan/wpa-wlp26s0.conf
** (generate:2452): DEBUG: 21:20:56.349: Creating wpa_supplicant service enablement link /run/systemd/system/multi-user.target.wants/netplan-wpa@wlp26s0.service
** (generate:2452): DEBUG: 21:20:56.350: NetworkManager: definition wlp26s0 is not for us (backend 1)

dmesg | grep wlp (I'm clearly getting a "14=MIC_FAILURE",but unsure of how to resolve this).

[    0.064845] audit: initializing netlink subsys (disabled)
[    1.060805] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    6.195188] iwlwifi 0000:1a:00.0 wlp26s0: renamed from wlan0
[    6.559179] IPv6: ADDRCONF(NETDEV_UP): wlp26s0: link is not ready
[   10.140355] wlp26s0: authenticate with 64:13:6c:0c:db:e8
[   10.142026] wlp26s0: send auth to 64:13:6c:0c:db:e8 (try 1/3)
[   10.151528] wlp26s0: authenticated
[   10.153119] wlp26s0: associate with 64:13:6c:0c:db:e8 (try 1/3)
[   10.164864] wlp26s0: RX AssocResp from 64:13:6c:0c:db:e8 (capab=0x411 status=0 aid=3)
[   10.166061] wlp26s0: associated
[   10.179938] wlp26s0: disassociated from 64:13:6c:0c:db:e8 (Reason: 14=MIC_FAILURE)
[   21.547731] wlp26s0: authenticate with 64:13:6c:0c:db:e8
[   21.549900] wlp26s0: send auth to 64:13:6c:0c:db:e8 (try 1/3)
[   21.552212] wlp26s0: authenticated
[   21.556260] wlp26s0: associate with 64:13:6c:0c:db:e8 (try 1/3)
[   21.566382] wlp26s0: RX AssocResp from 64:13:6c:0c:db:e8 (capab=0x411 status=0 aid=3)
[   21.567991] wlp26s0: associated
[   21.585954] wlp26s0: disassociated from 64:13:6c:0c:db:e8 (Reason: 14=MIC_FAILURE)

Apologies for the long post, I suspect my issue probably lies with an incorrect entry in the netplan file.

0

It was truly a newbie error, the wifi password was incorrect.

I figured this out by running: journalctl which clearly showed the 4-way handshake failed:

journalctl | grep wpa_supplicant 

wpa_supplicant[858]: wlp26s0: Trying to associate with 64:13:6c:0c:db:e8 (SSID='DBEB Hyperoptic 1Gbps Broadband' freq=2437 MHz)
wpa_supplicant[858]: wlp26s0: Associated with 64:13:6c:0c:db:e8
wpa_supplicant[858]: wlp26s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
wpa_supplicant[858]: wlp26s0: CTRL-EVENT-DISCONNECTED bssid=64:13:6c:0c:db:e8 reason=14
wpa_supplicant[858]: wlp26s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wpa_supplicant[858]: wlp26s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="DBEB Hyperoptic 1Gbps Broadband" auth_failures=14 duration=210 reason=WRONG_KEY
wpa_supplicant[858]: wlp26s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="DBEB Hyperoptic 1Gbps Broadband" auth_failures=15 duration=229 reason=CONN_FAILED

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.