1

When I run software update I get

  package operation failed

The updates downloaded ok.

The error window disappeared so fast, I could not write down errors.

I ran sudo apt-get dist-upgrade

  Errors were encountered while processing:
  /var/cache/apt/archives/apt_1.6.6ubuntu0.1_amd64.deb 
  E: Sub-process /usr/bin/dpkg returned an error code (1)

While following the answer below I got:

Unpacking apt (1.6.6ubuntu0.1) over (1.6.6) ... 
dpkg: error processing archive /var/cache/apt/archives/apt_1.6.6ubuntu0.1_amd64.deb (--unpack): 
unable to make backup link of './lib/systemd/system/apt-daily.timer' 
before installing new version: Operation not permitted dpkg-deb: 
error: paste subprocess was killed by signal (Broken pipe)
1

Months ago I added the immutable attribute to apt-daily.timer.

For some reason, software updater decided it did not like that.

After removing the attribute, software updater now works. ?

| improve this answer | |
  • Next time consider to disable these timers or mask them. File-system hacks are dangerous (as you have seen) :) – N0rbert Jan 30 '19 at 8:56
  • I don't see what I did as dangerous per se. I only did it because sometimes my customized apt.daily.timer is overwritten. It is just part of the learning process. I have a script that copies that version on each boot up. I keep a file of most changes I make just in case problems develop. :-) – fixit7 Jan 30 '19 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.