0

I'm struggling on using the wlan on a server 18.04.

this is my 01-netcfg.yaml:

network: version: 2 renderer: networkd ethernets: enp2s0: dhcp4: yes optional: true enp3s0: dhcp4: no optional: true enp4s0: dhcp4: no optional: true wifis: wlp1s0: optional: true dhcp4: no dhcp6: no access-points: "SSID": password: "SSID_pwd" bridges: br0: optional: true - enp3s0 - enp4s0 - wlp1s0 dhcp4: no addresses: [10.11.12.1/24] routes: - to: 0.0.0.0 via: 10.11.12.1 metric: 100 nameservers: addresses: [8.8.8.8,8.8.4.4]

i use netplan generate followed by netplan apply

There is no error in the configuration

This is the screen after networkctl and service systemd-networkd status

#networkctl
IDX LINK             TYPE               OPERATIONAL SETUP     
  1 lo               loopback           carrier     unmanaged 
  2 enp2s0           ether              routable    configured
  3 enp3s0           ether              no-carrier  configuring
  4 enp4s0           ether              no-carrier  configuring
  5 wlp1s0           wlan               no-carrier  failed    
  6 br0              ether              no-carrier  configuring


#service systemd-networkd status:
● systemd-networkd.service - Network Service
   Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled-runtime; vendor preset: enabled)
   Active: active (running) since Tue 2019-01-29 13:11:00 CET; 21min ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 672 (systemd-network)
   Status: "Processing requests..."
    Tasks: 1 (limit: 4642)
   CGroup: /system.slice/systemd-networkd.service
           └─672 /lib/systemd/systemd-networkd

Jan 29 13:11:00 3rdeye systemd-networkd[672]: enp2s0: IPv6 successfully enabled
Jan 29 13:11:00 3rdeye systemd-networkd[672]: wlp1s0: Could not join netdev: Operation not supported
Jan 29 13:11:00 3rdeye systemd-networkd[672]: wlp1s0: Failed
Jan 29 13:11:00 3rdeye systemd-networkd[672]: enp4s0: IPv6 successfully disabled
Jan 29 13:11:00 3rdeye systemd-networkd[672]: enp3s0: IPv6 successfully disabled
Jan 29 13:11:03 3rdeye systemd-networkd[672]: enp2s0: Gained carrier
Jan 29 13:11:05 3rdeye systemd-networkd[672]: enp2s0: Gained IPv6LL
Jan 29 13:11:06 3rdeye systemd-networkd[672]: enp2s0: DHCPv4 address 10.10.10.149/24 via 10.10.10.1
Jan 29 13:11:06 3rdeye systemd-networkd[672]: enp2s0: Configured
Jan 29 13:11:06 3rdeye systemd-networkd[672]: enp2s0: DHCPv6 address fdd1:f5cd:9b6a::a32/128 timeout preferred -1

SO far I haven't find any solution on how to let the wifi works nor find what it is wrong in interface setting

Please advise

Thanks

  • I don't believe that optional: true is a valid option for device wlp1s0 or br0. Any why would you bridge 2 ethernet devices with a wireless device? Also, try sudo netplan -debug generate to check your .yaml files. – heynnema Jan 29 at 15:38
  • The netplan return no problem from the .yawl. Everything works fine beside the Wlan. I will test if the boot hangs when I remove the option:true to any of the 2 interfaces. I work on an Apu2c4 and I aim to create a cctv box with router characteristics – mauro santini Jan 29 at 20:33
  • if I move the wlan outside the bridge with a static ip on networkctl the status of wlp1s0 change from failed to configuring but still no SSID transmitted... – mauro santini Jan 29 at 22:25
  • wlp1s0 doesnt "transmit" its SSID... it's used to CONNECT to the specified wireless SSID/password. Also, .yaml files are VERY FUSSY about indentation and spacing. They may pass the sudo netplan -debug generate step and still fail. Go to netplan.io/examples and view the examples there... as your .yaml file had some spacing/indentation issues that might effect all of this. – heynnema Jan 30 at 0:07
  • See my partial answer. Try using it as a starting point and see how far you get. Report back to @heynnema – heynnema Jan 30 at 0:21
0

Try this as a starting point. Adjust the static addresses for your specific environment.

network:
  version: 2
  renderer: networkd
  ethernets:
    enp2s0:
      dhcp4: yes
      optional: true
    enp3s0:
      optional: true
    enp4s0:
      optional: true
  wifis:
    wlp1s0:
      access-points:
        "SSID":
        password: "SSID_pwd"
  bridges:
    br0:
      interfaces:
        - enp3s0
      addresses: [10.11.12.2/24]
      routes:
        - to: 0.0.0.0
          via: 10.11.12.1
          metric: 100
      nameservers:
        addresses: [8.8.8.8,8.8.4.4]
    br1:
      interfaces:
        - enp4s0
      addresses: [10.11.12.3/24]
      routes:
        - to: 0.0.0.0
          via: 10.11.12.1
          metric: 100
      nameservers:
        addresses: [8.8.8.8,8.8.4.4]

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.