I have been using Ubuntu 18.04.1 LTS on a Dell Precision 5510 laptop with a Dell Thunderbolt 3 Dock, model TB16, for over two months with no issues. The system is regularly updated with the latest updates.

January 29th 2019, a notification for a new update appeared :

  • Several unused kernel files to be deleted
  • (update for Oracle's Virtual Box, seems very irrelevant)

I proceeded to install. However after rebooting, reaching the login screen and entering my password, I only had black screens and a completely unresponsive system.

After several reboots and attempts to diagnose the problem, only when I rebooted the system with the Dell Thunderbolt 3 Dock unplugged that the system successfully booted and displayed the desktop, menu bar...etc. Even then, when I re-plugged the dock, the system became unresponsive with a black screen.

I am currently looking into restoring the pre-update kernel using GRUB.

I'm interested to know if anyone, with a relatively similar setup, is experiencing this issue. Any other insights or ideas that could help are welcome.

Update :

Another report on this issue found (2 posts by the same author), it seems to affect only Dell docks but it is probably not restricted to Dell machines:


After most recent kernel update (4.15.0-44-generic) my tablet freezes whenever plugged into docking station

For now the issue has been resolved by restoring 4.15.0-43-generic using GRUB. I am holding from updating Ubuntu until the bug gets fixed.

marked as duplicate by karel, Eric Carvalho, Elder Geek, user68186, Charles Green Feb 20 at 14:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I have the same problem with a Lenovo T460s and a LENOVO® ThinkPad® Ultra Dock 90W. So the problem is neither Dell specific nor depends on the Thunderbolt dock, but seems to be a more general one. I had to downgrade to Kernel as Kernel seems to be buggy. – hantaho Jan 29 at 14:00
  • Same problem for me (ThinkPad X1 Carbon 5th + Dock Thunderbolt 3) Seems to work again after a downgrade to kernel 4.15.0-43 – Covich Jan 30 at 9:21
  • There are similar issues on my desktop + 2 monitors setup (both display port). Seems it is not necessary related to a dock, but more to external graphics. Downgrading the kernel works as a workaround. – Nijin22 Jan 30 at 9:31
  • 3
    Same problem here with XPS13 + dock and 2 monitors – Edson Medina Jan 30 at 12:23

I am posting to confirm I had this same issue after a kernel update yesterday.

Same symptoms, wouldn't boot with the dock plugged in. Plugging the dock in after laptop boots standalone caused the laptop screen to go black and everything lock up.

Tried with everything disconnected from the dock except power (as I thought the laptop was having issues going to the dual monitors).

Had to roll back from linux-image-4.15.0-44-generic (4.15.0-44.47) to linux-image-4.15.0-43-generic (4.15.0-43.46) and the Dell dock + monitor is working for me now.


Press ESC on boot (UEFI) or Left Shift if BIOS, then select advanced boot options. I went to older kernel (-43). Confirmed issue wasn't occurring for me on -43, so removed -44.

sudo apt-get purge linux-image-4.15.0-44-generic
  • I had to add -f to the purge command due to "not empty" errors. Thanks. – isherwood Jan 30 at 19:55

Upgrading kernel to 4.15.0-45 (available today on Ubuntu repositories) solved if for me! At last!

  • I can confirm that updating the kernel solved the problem. First, do uname -a to verify that you have 4.15.0-44. Then, do sudo apt-get dist-upgrade to update. After rebooting, I was able to use my dock as before. – L42 Feb 7 at 13:58
sudo apt remove linux-image-4.15.0-44-generic linux-headers-4.15.0-44-generic

This helped me. Ubuntu 18.04. Dell XPS 9570 + thunderbolt tb16

  • 3
    You probably don't want to remove the currently active kernel, though. Reboot into -43 first. – isherwood Jan 30 at 19:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.