36

I upgraded from 16.04 to 18.04. When I press Ctrl+Alt+F3 I get the terminal which prompts for the username. When I type my username and press Enter, it doesn't wait for my password (its as if I pressed Enter without entering anything). Even if I enter something, the text shown in plaintext and then it keeps on saying my password is wrong. After few times, the screen is cleared and it prompts for my username again and the same loop goes on.

  • 4
    Same problem here since yesterday with U18.04.1. I think it's since I (was) updated from kernel 4.15.0-43 to 4.15.0-44. The GUI login works, TTY login seems to automatically hit RETURN after username is entered. /var/log/auth.log repeatadly shows login[939]: pam_unix(login:auth): conversation failed, login[939]: pam_unix(login:auth): auth could not identify password for [pduck], login[939]: FAILED LOGIN (1) on '/dev/tty3' FOR 'pduck', Authentication failure. Can you confirm that? What does uname -r show? – PerlDuck Jan 30 at 10:43
  • 2
    Not @pranphy but I'm seeing the same things in the auth.log. However it says "FAILED LOGIN (1) on '/dev/tty6' FOR 'UNKNOWN', Authentication failure" despite printing my username on the "could not identify password for ..." line. It then repeats that last error several times, ending with "Error in service module" instead of "Authentication failure". uname -r outputs 4.15.0-44-generic – Rob Mosher Jan 30 at 12:01
  • 1
    @PerlDuck Exactly as @RobMosher said, my kernel version is 4.15.0-44-generic and the first error message includes the username and the other ones don't even get the username because tty never waits to get username until too many attempts (5) and resets to wait for username again. – pranphy Jan 30 at 14:48
  • 5
    At least, someone already reported it: bugs.launchpad.net/ubuntu/+source/shadow/+bug/1812095 – PerlDuck Jan 30 at 14:59
  • It seems to be the issue with linux kernel version 4.15.0.-44-generic. I updated to a newer kernel (4.20.5) and the issue is resolved. – pranphy Jan 30 at 20:48
18

Same TTY problem with 4.15.0-44-generic on my Ubuntu Mate 18.04

I just updated to 4.15.0-45-generic, but it still doesn't fix the problem.

Only workaround that I found is to switch back to old kernel 4.15.0-43-generic.

I put on hold and removed the new kernels:

sudo apt-mark hold linux-*-4.15.0-4[45]-generic
sudo apt remove linux-*-4.15.0-4[45]-generic

NB: Of course, old kernel linux-*-4.15.0-43-generic has to be present ;) If not, then install with:

sudo apt install linux-{image,headers}-4.15.0-43-generic

Then the system boots fine on 4.15.0-43 and tty login works, but then I had problems with my second monitor (but this, I guess, it's totally another problem).

UPDATE: I fixed the second monitor problem, in fact it was a video acceleration problem, related to missing kernel modules with the previous 4.15.0-43 kernel. The command "inxi -G" helped, me showing that my videocard was using 'fbdev' driver (framebuffer, no gpu acceleration) and not the accelerated 'modesetting' driver.

example1 (kernel modules installed):

Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz 
OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.2

example2 (kernel modules NOT installed):

Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
Display: x11 server: X.Org 1.19.6 driver: fbdev unloaded: modesetting,vesa resolution: 1920x1080~60Hz 
OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.2

So the correct syntax for the command above is:

sudo apt install linux-{image,headers,modules,modules-extra}-4.15.0-43-generic
  • 1
    I am using kernel 4.15.0-45 on two different and fully updated systems. One uses a Kubuntu 18.04.1 installation and the other uses a Xubuntu 18.04.1 installation. The issue occurs on the one running Kubuntu only. The other one accepts the password in console mode ok like nothing ever happened. How can this be explained? – Stormlord Feb 5 at 10:01
  • Weird issue. I've my laptop running Ubuntu Mate 18.04.1 where the issue is present with 4.15.0-45/44 but not with 4.15.0-43. But on my Virtualbox VM with Ubuntu Mate 18.04.01 and kernel 4.15.0-45, the same issue is not present. – Andrea Turbiglio Feb 5 at 14:52
  • I am using kernel 4.15.0-45 with Mint Cinnamon and I've the same issue. – boctulus Feb 12 at 4:26
  • I forgot to mention ... I've also using framebuffer, no gpu-acceleration. This answer is very accurate. – boctulus Feb 12 at 4:34
8

Another option is to use another kernel in grub boot menu (if one is available), after booting:

Choose "Advanced options for Ubuntu"
In my case 4.15.0.-43 was working correctly

Just try, what is available in the list (but maybe rather not the topmost entry, thats the one, that doesnt work, and not recovery mode)

enter image description here

8

This is unbelievable - today I went to this bug on Ubuntu 16.04.5 LTS (Xenial Xerus) with all updates and without PPAs on physical hardware.
So the problem was with 4.4.0-142-generic kernel. The symptoms was exactly same as in question. Getty in text console sends "Enter" and does not allow me to enter my password. Shows Login incorrect instead.

So I removed this buggy kernel and installed 138 instead (with method similar to USB-problem):

sudo apt-get purge linux-image-generic linux-headers-generic
sudo apt-get purge linux-image-4.4.0-139-generic linux-headers-4.4.0-139-generic \
linux-image-4.4.0-140-generic linux-headers-4.4.0-140-generic \
linux-image-4.4.0-141-generic linux-headers-4.4.0-141-generic \
linux-image-4.4.0-142-generic linux-headers-4.4.0-142-generic
sudo apt-get install amd64-microcode intel-microcode thermald
sudo apt-get autoremove

sudo apt-get install linux-image-4.4.0-138-generic linux-image-extra-4.4.0-138-generic
sudo apt-get install linux-headers-4.4.0-138 linux-headers-4.4.0-138-generic

and rebooted afterwards. I/we need to wait for normal stable kernel.

Warning: do not upgrade kernel to 4.4.0-142-generic if you need console login. Subscribe to the bug 1813873 and after the confirmation of the fix - install newest kernel back with sudo apt-get install linux-image-generic linux-headers-generic.

1

Kernel upgrade to 4.20.0 helped.

  • 4
    How did you install this kernel? – dessert Feb 1 at 0:02
  • yes i would like to find out how to install with Linux Mint aka Ubuntu 4.20.0? – Patrik Laszlo Feb 11 at 6:01
  • I've installed the kernel 4.20.7 using 'Ukuu´ and everything works fine... but when I tried to use x86-energy-perf-policy I realized why I should not use 'unsupported' kernels. – boctulus Feb 12 at 4:24

protected by Community Feb 1 at 9:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.