(I am running Xubuntu 18.10.)

I want clipboard support in my Vim, which isn't present in the vim package in apt, so I compiled Vim myself with +clipboard. I then proceeded to install it using checkinstall. This works fine.

However, after some time, I will notice my Vim no longer supports the clipboard. vim --version shows -clipboard; it's clear that it has reverted to the system version.

What could be causing this? Where can I look to figure out what is making my installed version disappear? checkinstall produces a .deb file which I can install using the Software GUI app; but when it reverts, (my build of) Vim is no longer listed as installed in that app.

I am experiencing another issue with something happening periodically, which I include here only because it might be relevant. I have set proxy variables in various places including /etc/environment and /etc/profile.d/office_proxy.sh, because I need these for the office. When at home, I will typically manually go and comment all of these out & relog to disable the proxy. However, some time after logging in, the proxy variables will reinstate themselves. I'm 99% certain it's not a script of mine that is setting the proxy; I suspect Xubuntu is doing this somehow. Again, I only mention this here because this is another seemingly time-based behaviour.

  • 2
    It looks like it might just be apt "upgrading" my Vim to the apt version. I have applied apt-mark hold vim; let's see if that fixes the problem. – henrebotha Jan 28 at 8:16
  • If you know the solution, then you should add it as answer and accept it. – Ralf Jan 29 at 21:13

This was caused by apt overriding my own version of Vim whenever I ran it. The solution was to use apt-mark hold vim to tell apt not to try to upgrade Vim.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.