0

I installed Ubuntu 16.04 32 Bit Desktop (kernal - 4.15.0-29-generic) version in my machine (x64). And it freezes frequently. When I googled I found that this a Cstate defect in Kernal which happens in BayTrail processors.

I applied the following fixes, but it still freezes.

  1. Changed the Max Cstate to 0 and also 1 and ran the command sudo update-grub (and restarted).Also tried different combinations of kernal boot parameters like:

    GRUB_CMDLINE_LINUX_DEFAULT="quite splash intel_idle.max_cstate=1" GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi=force intel_idle.max_cstate=0"

  2. Also tried the shell script - c6off+c7on.sh and made this as service, enabled it and rebooted.Got the following output when ran the command service cstatefix status. And I hope the service has run the shell script and exited or should this service keep on running? (I removed the cstate parameter in grub when I enabled this service)

● cstatefix.service - My Script Loaded: loaded (/etc/systemd/system/cstatefix.service; enabled; vendor preset Active: inactive (dead) since Mon 2019-01-28 13:43:54 IST; 51s ago Process: 824 ExecStart=/usr/bin/c6off+c7on.sh (code=exited, status=0/SUCCESS) Main PID: 824 (code=exited, status=0/SUCCESS)

Is there any other permanent fix for this issue?

If not what hardware (CPUs and Graphic card, and mother board) should I replace which will not be affected by this CState Issue.

Note:My Current processor is bit old - Intel core i3-370M with Intel HD Graphics.

  • 3
    32 bit desktop is probably not the right release. Have a look at releases.ubuntu.com and consider if a 64 bit would be preferable. You always can try before installing. – Dominik Cornice Jan 28 at 8:31
  • And the i3-370M is NOT a "Bay Trail". Those specific "fixes" for the Bay Trail family are doomed to NOT work with yours and can even make it worse. Use the proper architecture as mentioned above, for starters. – GabrielaGarcia Jan 28 at 18:29
  • I installed 18.04 LTS x64 and it was freezing too. So I tried older ubuntu version 12.04 LTS x64 and there is No freeze problem in this version (Kernal - 3.13.0-32-generic), and did not update any cstate parameter. – user1925406 Jan 29 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.