My current setup:

ASUS Prime X470 Pro

Samsung 960 EVO Series PCIe NVMe - M.2 SSD (LVM encrypted)

Nvidia Quadro NVS 295 PCIe x1

2 Monitors

AMD Ryzen 7 Series CPU

This setup works perfectly ok except in the graphic department. It's a little "slow".

I had gotten a Nvidia 8800 GTS SSC Edition 640MB card from a friend to replace it. The card works perfectly fine under his Windows setup. Linux. Not so much.

Doing the research, this card and my current card both use the same Nvidia driver (340.107). I went the route of just installing the new card but I get the following message during boot:

WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Volume group "ubuntu-vg" not found
Cannot process volume group ubuntu-vg
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Reading all physical volumes. This may take a while...
Found volume group "ubuntu-vg" using metadata type lvm2
WARNING: failed to connect to lvmetad. Falling back to device scanning.
2 logical volume(s) in volume group "ubuntu-vg" now active
/dev/mapper/ubuntu--vg-root: clean, 401546/60907520 files, 8689639/243620864 blocks

Installing the NVS 295 back in allows the system to boot properly.

For kicks, I uninstalled the 340 drivers and installed the 390 drivers. While it did allow the system to boot, it did not work out as I had hoped. Only one monitor worked and it was limited to 1024x768.

I tried uninstalling the video drivers but when I rebooted I got the following: green dots scattered on a black background

I tried booting up with just one monitor connected (and no drivers installed) and it went to a black screen.

Output from lsmod while booted in recovery mode:

nvidia_uvm    36864  0
nvidia     10559488  1 nvidia_uvm
drm          401408  2 nvidia

Tech info on the card per the system:

VGA compatible controller: NVIDIA Corporation G80 [GeForce 8800 GTS] (rev a2) (prog-if 00 [VGA controller])
Subsystem: eVga.com Corp. G80 [GeForce 8800 GTS]
Flags: bus master, fast devsel, latency 0, IRQ 86
Memory at f6000000 (32-bin, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f4000000 (64-bit, non-prefetchable) [size=32]
I/O ports at d000 [size=120]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128k]
Capabilities: [60] Power Management version 2
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [120] Power Budgeting <?>
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia

I did see some steps in How to install nvidia driver with secure boot enabled? but I wasn't sure if they may be applicable so, in order to not cause unintended harm, I haven't followed them.

Any ideas on how to get this to work? All of the other questions here don't seem to help solve the problem.


  • The driver version for GeForce 8800 GTS is 340. – GabrielaGarcia Jan 28 at 18:33
  • 340 is what I originally had installed. I had only installed 390 for testing (which didn’t work out). 340 is what is currently installed. – Ryan Jan 29 at 23:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.