I have recently been using multiple workspaces in unity but have run into a bug that is making it very difficult to do this effectively.

The problem is with alt+tab. When I am focused on a window that is not in the primary (top-left) workspace one of two things happens:

  1. Unity restarts (the launcher and menu bar disappear and screen flashes blank before everything reappears) and all of my windows are moved to different workspaces. The focused window is always moved to the primary workspace and other windows are typically moved one workspace to the left. alt+tab will usually function normally after this.

  2. Unity completely crashes. The windows in the current workspace are still there, but the launcher and menu bar are gone, I cannot switch between workspaces, and none of the hotkeys work.

The same issues occur when using alt+` as well.

I have installed ccsm, but have made only minor adjustments with it. I am still using the Unity switcher. I actually uninstalled ccsm hoping that would resolve the issue, but the issue persists.

Is there some resolution to this issue? I like Unity and want to keep using it, but having to use the mouse to switch between programs is irritating and enough reason to switch to Gnome.

  • Before you press alt+tab click first on the desktop.
    – Blood Fred
    Mar 9, 2012 at 3:01
  • I tried clicking on the desktop first, but the result is the same.
    – Ruslanchik
    Mar 9, 2012 at 3:16
  • try to run "fsck" in the terminal
    – Blood Fred
    Mar 9, 2012 at 6:30
  • if you using compiz just try to reinstall all settings to default
    – hingev
    Mar 26, 2012 at 17:09
  • I have this problem too, I use AMD (ATI) propietary Driver. Maybe this is the reason of the crash? :( But there's an odd behavior though, because ALT+TAB works some times, regardless of how many workspaces or applications I'm running, and other times it just dies.
    – victorhqc
    Apr 12, 2012 at 3:38

2 Answers 2


Did it run smoothly before?, if yes try to reset settings using Ubuntu tweak's desktop recovery tool, If no try to use another switcher, if problem exists, you may have some issues with CCSM try reinstalling CCSM (complete remove including config files)

  • I think you have to purge CCSM to remove the config files.
    – mchid
    Jan 23, 2019 at 16:59

Same issue was faced by us and we managed to fix it by using several solutions.

Run fsck as mentioned first. In our case it found something to be fixed.

While seeking CCSM we found MyUnity as the appropriate customization tool, and encountered errors with meeting the dependencies. Which appears to be the cause of error here.

Anyways, several searches made us do "sudo apt-get install -f" and we managed to get this problem resolved after a restart.

This would help. We are new with Ubuntu too and are loving it.

TNG- Cheers from Chandigarh.

  • not sure what exactly helped, but running fsck and installing MyUnity seem to have fixed it for me
    – parxier
    Apr 15, 2012 at 5:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .