0

Backing up using Deja Dup to an external drive is failing, it used to work fine. Last backup was 43 days ago. When I attempt to backup, Deja Dup decides to do a full fresh backup not incremental. At some point it reports Backup failed. "Failed with an unknown error", and gives the call stack below. I've tried this 3 times but get the same result. I'm using Ubuntu 18.10.

Traceback (innermost last):

File "/usr/bin/duplicity", line 1555, in <module>
  with_tempdir(main)
File "/usr/bin/duplicity", line 1541, in with_tempdir
  fn()
File "/usr/bin/duplicity", line 1393, in main
  do_backup(action)
File "/usr/bin/duplicity", line 1511, in do_backup
  full_backup(col_stats)
File "/usr/bin/duplicity", line 572, in full_backup
  globals.backend)
File "/usr/bin/duplicity", line 454, in write_multivol
  (tdp, dest_filename, vol_num)))
File "/usr/lib/python2.7/dist-packages/duplicity/asyncscheduler.py", line 146, in schedule_task
  return self.__run_synchronously(fn, params)
File "/usr/lib/python2.7/dist-packages/duplicity/asyncscheduler.py", line 172, in __run_synchronously
  ret = fn(*params)
File "/usr/bin/duplicity", line 453, in <lambda>
  vol_num: put(tdp, dest_filename, vol_num),
File "/usr/bin/duplicity", line 342, in put
  backend.put(tdp, dest_filename)
File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 395, in inner_retry
  % (n, e.__class__.__name__, util.uexc(e)))
File "/usr/lib/python2.7/dist-packages/duplicity/util.py", line 79, in uexc
  return ufn(unicode(e).encode('utf-8'))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 37: ordinal not in range(128)
  • Is there enough room on the drive for an additional full backup? – Organic Marble Jan 27 at 21:44
  • Yes I am backing up 143GB and there is 484GB free. – Matt Swan Jan 27 at 22:16
  • Is the external drive a remote Google Drive? – tidelake Jun 12 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.