I have a fingerprint reader on my Dell Vostro. Does anyone know of any proper Fingerprint reader which can integrate with LightDM? I have heard of Fingerprint GUI but that works with GDM as per the development notes. It would be great if someone can let me know.



7 Answers 7


Fingerprint GUI is working just fine in Ubuntu 12.04 Beta1 (LightDM). You can log in, unlock screen, and authenticate everything in the GUI and also "sudo's" in a terminal. I'm using it on an old ThinkPad R52 with integrated SGS Thomson Microelectronics Fingerprint Reader.

Install instructions: Fingerprint GUI

  • 2
    Thanks. It installs fine. Unfortunately, my fingerprint module for dell is not supported . the ID is 138a:0008. It is not in the list of supported devices. Let me know if there is anyother way i can enable the support. Regards.
    – Ubuntuser
    Mar 17, 2012 at 1:57
  • Link to how it can be done for dell vostro 3300 laptops : tuxtrix.com/2012/05/how-to-activate-validity-fingerprint.html
    – Ubuntuser
    May 29, 2012 at 14:56
  • No device found for Thinkpad t430s.. :( Any help somewhere?
    – Pierre
    Sep 27, 2012 at 7:55
  • Works perfectly for me using Ubuntu 12.04 x64 on a Thinkpad T510.
    – Enigma
    Oct 26, 2012 at 18:56
  • This is not capable of unlocking the Gnome Keychain with a fingerprint scan right? So it is kind of useless since you still need to enter your password.
    – Kvothe
    Nov 18, 2020 at 14:05

This is available in the repositories as well a sourcefourge


ThinkFinger is a driver for the UPEK/STMicroelectronics fingerprint reader. The device is usually found either as a standalone USB device, built into USB keyboards or built into laptops (usually from Dell, IBM/Lenovo and Toshiba).

pam_thinkfinger is a Pluggable Authentication Module that allows the user authenticates through his fingerprint.

The recommended package thinkfinger-tools can be used to acquire, verify and automatically store user fingerprints.

Homepage: http://thinkfinger.sourceforge.net

PAM wiki

  • this is a very old program. will it work in 12.04? it was last updated in 2007. also, its not in the repositories.
    – Ubuntuser
    Mar 10, 2012 at 21:57

This has worked flawlessly for me through Ubuntu 12.04/12.10 with an SGS Thomson Microelectronics Fingerprint Reader.

sudo add-apt-repository ppa:fingerprint/fingerprint-gui
sudo apt-get update
sudo apt-get install libbsapi policykit-1-fingerprint-gui fingerprint-gui

Exit your session, login again and run Fingerprint GUI to set it up [0483:2016]


fingerprint-gui doesn't work for me. But fprint project works fine for Ubuntu 14.04 and Vostro 5480. Try it:

sudo add-apt-repository ppa:fingerprint/fprint
sudo apt-get update
sudo apt-get install libfprint0 fprint-demo libpam-fprintd gksu-polkit

There is an issue with 1.05 under Ubuntu 10.04 with upek devices. I am using 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor on some hosts and a Lenovo W520. Creating the symbolic links:

cd /usr/lib
ls -l libbs*
-rw-r--r-- 1 root root 4219952 Oct  9  2011 libbsapi.so
lrwxrwxrwx 1 root root      20 May 14 09:00 libbsapi.so.4.0 -> /usr/lib/libbsapi.so
lrwxrwxrwx 1 root root      15 May 14 09:05 libbsapi.so.4.3 -> libbsapi.so.4.0

as described in


fixes the problem. My old fingerprints are recognized, I can register new ones without an endless loop in fingerprint-gui and it accepts all fingers during login or sudo and not only the leftmost one.


With Ubuntu 13.04 after installing libbsapi policykit-1-fingerprint-gui fingerprint-gui, when we try running fingerprint-gui especially those who have 138a:008 (VFS301), the device would not sop after first initiation and hence you cannot proceed.

This has been fixed in the libfprint 1.5.1 version and hence download the source and compile it. Do not use the launchpad version as it has dev_open identification issue.

Also after installing make ln -s for /usr/local/lib/libfprint.s0.0.0.0 to /usr/lib/libfprint.s0.0.0.0. Otherwise it would point to the old version installed using apt-get.

This happened to me and after installing latest version of libfprint, I succeeded.

  • 1
    This is a very specific solution to a problem/question not really asked here. Perhaps you should create your own Q&A for this specific device?
    – gertvdijk
    Oct 6, 2013 at 17:44

You can follow this unix.stackexchange link also to check your fingerprint versions

This Worked for me as posted on this bugs.launchpad.net link:

"Ok guys I have built a deb package for 64 bit systems. After you download the package i attached you just need to sudo dpkg -i and it will install the driver. If you want the integrated ubuntu fingerprint features for login and sudo, apt-get install fprintd libpam-fprintd. Then go to users and you will see the fingerprint login button option. Enroll your fingerprint and voila! The only annoyance is that on the login screen when it asks for your fingerprint the process isn't like windows. You swipe your finger and if the fingerprint is recognised it will display a login button you have to click. If the fingerprint isnt recognised it will time out and ask for you user password."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.