2

I have just upgraded from 18.04 to 18.10 with full encryption on my laptop (Asus UX305F) but my usual encryption password does not work anymore. I don't know what caused that, maybe the keyboard layout was changed but I don't know how to switch it back, since all I'm being asked on the screen is to key in the password. I would be really grateful if someone could help me.

Thanks a lot.

2
  • 4
  • In order to check whether this is an issue with the keyboard layout (the alleged duplicate above) or with encryption, go to a terminal console (for example crtl+alt+f2) and try a login with the usual name and password, If the login is successful, the trouble is in the encryption: this is evident by typing ls that show only two files README.txt and Access-Your-Private-Data.desktop. – XavierStuvw Aug 20 '19 at 21:32
1

The only way to revert a system if you don't have the password is to reinstall using a backup. In fact, even if you have the password that is the only practical way to go backwards. Before you try that there are some things worth trying:

The best guess hope is that the keyboard on your boot screen is somehow messed up. In this case probably the easiest way is to

  1. Make a new bootable USB stick
  2. Boot into live system mode (do not attempt to install)
  3. Attempt to mount the drive from your system
  4. Enter the password you know
  5. Assuming this works, now change to an encryption password with only standard lower case letters
  6. Reboot and use the new encryption password which should work on most keyboard layouts (except ones like the German ones with letters in different locations)

In the case that the password still doesn't work in live system mode then the most likely explanation is that your old system had a different layout during boot. In this case, you can experiment with setting different keyboard layouts in the live system and entering your password as you would have normally. Definitely try EN-US and EN-UK but also look at the ones that were next to your normal keyboard in the list during installation.

If you have really valuable data that wasn't backed up, unfortunately it is likely lost, however you can consider taking a low level image of the whole disk or just replacing it and keeping it. This will allow you to try again later.

3
  • Thanks a lot. I have was able to mount the drive, the password was working. But I'm not sure how to do step 5. How can I change encryption password since it's a live session user? I tried the command line with sudo cryptsetup luksChangeKey /dev/sda2 but it does not seem to be working. – Arnaud Malfoy Jan 27 '19 at 12:04
  • 1
    @ArnaudMalfoy you should be able to do it by opening the graphical "disks" tool (I think it's installed on the livecd; if not install it) then finding your main system disk, looking for the LUKS partition and simply selecting change passphrase in its settings section – Michael Jan 27 '19 at 12:21
  • Thank you so much, it worked like a charm. I'm so glad I did not have reinstall the whole system. It's great to have such a helpful community. Thanks again. – Arnaud Malfoy Jan 27 '19 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.