0

I thought this would be trivial, but after two hours of googling and experimenting still nothing works.

I want to use the ROS+Kinetic-lxde o/s sd image for the Raspberry Pi. As far as I can tell this is Lubuntu. Unfortunately the keyboard layout in the image does not match my keyboard, so I need to change it.

So far I have tried localectl from the command line. That does not do anything. I tried localectl list-keymaps and that says it can't find any console keymaps.

I added the 'Keyboard Layout Handler' applet to the task bar and set the keyboard through that. My changes were lost when I rebooted.

I tried sudo dpkg-reconfigure keyboard-configuration. That let me set up the keyboard, but again the changes were lost after a reboot.

I tried editing the file /etc/default/keyboard, but that already had the correct settings and they are doing no good.

So, how can I permanently set the keyboard type ? It seems crazy that it can't be done easily.

0

Here details from the Lubuntu/Keyboard article section Keyboard Mapping:

The simple way to do this is to launch Lxkeymap (under Preferences.)

It's likely that /etc/defaults/keyboard defines the default keyboard layout used by the system and X server, but it's possible that Lubuntu's desktop environment (LXDE) has it's own configuration files that override that.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.