1

I am having problems installing Ubuntu 18.10 in my system. I was trying to install ubuntu Budgie flavor but that is where my problems started and then I tried the original ubuntu 18.10 and it gave me the same problem I have done it in UEFI and bios mode and in both it has given me the same problem.

My system Specs are:

  • Motherboard - Gigabyte AB350M-DS3H
  • CPU - AMD Ryzen 5 2400G
  • RAM - Timetec 2400mhz 16GB
  • Graphics - XFX Radeon RX 560

The problem is that every time it boots into installing directly or live boot they both hit me with a Fatal Error that indicates that the kernel panic, one time it gave me a reason which pointed out that the init wasn't found.

When it first starts up it runs AMD-VI completion-wait loop timed out before the error pops out.

I already tried running the installation with the integrated graphics card as suggested in another thread, but it gave the same error.

Final Edit: I have given up on dealing with linux for now. This hardware doesnt support a stable linux experience at all. After IOMMU being disabled and the instalation finishing a lot more problems occur like screen stutering which I had to install amdgpu-pro to get it to stabalize, vulkan wont work even when installed properly says it can't load "radeoni". There is also a performance hurdle, but I don't believe its linux fault but AMD's poor linux support.

In the future I'll build a new machine around Linux and will most likely just go intel+nvidia.

  • These are rather obvious, but did you verify the download of your ISO was valid? (ie. verify checksums), then did you verify the write-to-thumb-drive was valid? (ie. check install-media) [tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu] – guiverc Jan 27 '19 at 0:43
  • If it's telling you that init is not found, I'm guessing your video card is not the problem. Either your init file was deleted, or the system can't read it. Can you boot from a USB, CD, or some other external storage? – TSJNachos117 Jan 27 '19 at 0:47
  • If you search AskUbuntu "ryzen 5 ubuntu install" you will see lots of problems, and few answers that were marked as accepted. Please try booting with the kernel parameters "noacpi nomodeset" in the GRUM_CMDLINE_LINUX_DEFAULT" as explained in https://askubuntu.com/a/111298/283721 – Charles Green Jan 27 '19 at 2:02
  • Download Ubuntu 18.10 onto a clean Cd from a reliable source – user610658 Jan 27 '19 at 2:45
  • You may need newer kernel & drivers than 18.10 has. If willing to experiment you can try 19.04, but it will not be released until April, so you may get breakage or issues as it keeps getting updated. Daily builds cdimage.ubuntu.com/daily-live/current – oldfred Jan 27 '19 at 4:32
1

You have to disable IOMMU in BIOS for the errors to get fixed.

I had trouble with Ubuntu but never understood what was the problem until I ran Manjaro and that distro gave me more insight into my error by mentioning a problem with IOMMU AMD V. And so I went to BIOS, disabled IOMMU and both Ubuntu (any version) and Manjaro booted into their live session. Of course, I don't know if it can be installed yet or how well it will respond after installation but I finally was able to boot into the live distro which is good progress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.