So I am VERY new to linux (only been using a couple of days) and I'm struggling.

The system settings cannot open (the icon is present and it shows from the menu in the top corner but it just spins it's wheels for a moment when initiated and gives up before opening the window). I also can't shutdown, restart, or sleep. I've found a ton of walkthroughs on how to fix this by going into the system settings, but... Most of what I'm reading to fix accessing the systems settings is going completely over my head and I keep finding myself googling in circles. To make matters worse, the issue keeps corrupting my git repository every couple days.

Is there anyone who would be able to walk my through diagnosing the cause of these issues that can dumb it down back to newbie levels?

I'm on Ubuntu 18.04 (I think Bionic Beaver, sorry I didn't do the initial set up ). I also don't know my laptop's specs aside from it being an Asus. Since I can't access the system settings at the moment I'll need to look that up via the terminal, but I'm not sure how to find the info.

I've been trying to fix this for four days :(.


Try reinstalling gnome-control-center by opening a terminal (Ctrl+Alt+T) and type

sudo apt remove --purge gnome-control-center
sudo apt autoremove
sudo apt install gnome-control-center
  • 1
    Sadly this didn't change anything. – amigurumidragon Feb 4 '19 at 21:25
  • Is there any errors displayed when you try to launch gnome-control-center from the terminal ? – s4iya Feb 4 '19 at 22:03
  • Nothing. It just keeps trying to run until I kill the terminal. Never opens, no error. – amigurumidragon Feb 4 '19 at 22:36
  • Is it only the settings app or does this happen with other applications as well? – Neni Feb 4 '19 at 22:46
  • 1
    Try it with gnome-control-center -v, it should display a message. It could also be that there's already an instance of gnome-control-center running but hanging in the background, try killing it with killall gnome-control-center. Can you open it now ? If yes, share your Gnome version with gnome-shell --version – s4iya Feb 4 '19 at 22:54

First of all, make sure you are not using Wayland: On the login page, click the little cog and select 'Ubuntu', not 'Ubuntu on Wayland'!


sudo apt-get install --reinstall ubuntu-desktop
sudo systemctl restart gdm3
  • Much obliged - this worked for me, but after restart otherwise ubuntu cannot load after login. – Dejan Toteff Oct 4 '19 at 15:24

Hello I am using Ubuntu 18.04 with cinnamon 4.0.9 as my desktop manager and had the same problem. I looked at my system logs and noticed that I had a problem with a missing nemo and girl2 package. I went to synaptic and searched for the packages by typing in the synaptic search window and typed cinnamon and saw this packages were not install after clicking on the checkbox to install the packages my system setting were again functional from the menu. I would suggest you click on the system setting menu button and then go to the system logs and check for what missing or throwing an error code (donot need to understand the what the code means) and then going to synaptic be sure "all" is selected on the left panel and then typing in gdm in the search window and see if the packages are installed that threw the error code if not select them by clicking on the package name and then select "mark for install" in the popup if you do this click on "apply" in the main menu bar of synaptic. Good Luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.