0

Lately I've successfully had a clean install of Lubuntu (18.10) on my Asus x205ta with the instructions at this thread:How to install Lubuntu 16.04 on the ASUS X205TA (F205TA)

However, due to a report closing in and I have troubles using libreoffice I installed win10 back. Now I want to go back to Lubuntu but at the end of installation there's a window pop up with message as follows: External command finished with errors.

Command apt install -y --no-upgrade -o Acquire::gpgv::Options::=--ignore-time-conflict grub-efi-$(if grep -q 64 /sys/firmware/efi/fw_platform_size; then echo amd64-signed; else echo ia32; fi) finished with exit code 100. Output: WARNING: apt does not have a stable CLI interface. Use with caution in scripts. Reading package lists... Building dependency tree... Reading state information... The following additional packages will be installed: grub-efi-ia32-bin Recommended packages: grub-efi-ia32-signed The following packages will be REMOVED: grub-gfxpayload-lists grub-pc The following NEW packages will be installed: grub-efi-ia32 grub-efi-ia32-bin 0 upgraded, 2 newly installed, 2 to remove and 0 not upgraded. Need to get 0 B/682 kB of archives. After this operation, 4831 kB of additional disk space will be used. Get:1 cdrom://Lubuntu 18.10 _Cosmic Cuttlefish_ - Release amd64 (20181017.2) cosmic/main amd64 grub-efi-ia32-bin amd64 2.02+dfsg1-5ubuntu8 [635 kB] Get:2 cdrom://Lubuntu 18.10 _Cosmic Cuttlefish_ - Release amd64 (20181017.2) cosmic/main amd64 grub-efi-ia32 amd64 2.02+dfsg1-5ubuntu8 [47.1 kB] dpkg-preconfigure: unable to re-open stdin: No such file or directory E: Can not write log (Is /dev/pts mounted?) - posix_openpt (19: No such device) (Reading database ... 243251 files and directories currently installed.) Removing grub-gfxpayload-lists (0.7) ... Removing grub-pc (2.02+dfsg1-5ubuntu8) ... Selecting previously unselected package grub-efi-ia32-bin. (Reading database ... 243231 files and directories currently installed.) Preparing to unpack .../grub-efi-ia32-bin_2.02+dfsg1-5ubuntu8_amd64.deb ... Unpacking grub-efi-ia32-bin (2.02+dfsg1-5ubuntu8) ... Selecting previously unselected package grub-efi-ia32. Preparing to unpack .../grub-efi-ia32_2.02+dfsg1-5ubuntu8_amd64.deb ... Unpacking grub-efi-ia32 (2.02+dfsg1-5ubuntu8) ... Setting up grub-efi-ia32-bin (2.02+dfsg1-5ubuntu8) ... Processing triggers for man-db (2.8.4-2) ... Setting up grub-efi-ia32 (2.02+dfsg1-5ubuntu8) ... Unknown terminal: qterminal Check the TERM environment variable. Also make sure that the terminal is defined in the terminfo database. Alternatively, set the TERMCAP environment variable to the desired termcap entry. debconf: whiptail output the above errors, giving up! dpkg: error processing package grub-efi-ia32 (--configure): installed grub-efi-ia32 package post-installation script subprocess returned error exit status 255 Errors were encountered while processing: grub-efi-ia32 E: Sub-process /usr/bin/dpkg returned an error code (1)


Error message pic Since I don't have any background on computer science or anything like that, I can only assume that bootia32.efi somehow didn't work as planned (Correct me if I'm wrong), but when I installed Lubuntu for the first time this didn't happend. So here I am, looking for any suggestions and advice. If I can't fix this I'll just have to back to win10, but I've just made up my mind trying out linux during my two-week vacation. Your words mean a lot to me, thanks!

  • 1
    Even I tried to tidy up is difficult to help with the given output. I would try to start from scratch with the usual way of creating a Lubuntu live pendrive with Startup Disk Creator, boot with it, clean partitions with GParted and install it as usual. Did you tried that? – Pablo Bianchi Jan 26 at 5:33
  • I used Rufus on win10 to make the USB drive a live one, is it alright? No I haven't used GParted to clean all the partitions but during installation the program did ask me to manual distribute partitions and it seemed to do the job. Would you recommend using GParted? – thetample Jan 26 at 5:39
  • Rufus or unetbootin should be OK to create the live pendrive. If you don't need to leave other (maybe Windows) partitions from installation process you can choose to remove everything and install Lubuntu all over the hard disk (avoiding the need of GParted). Anyway: Please tidy up the errors you get to make it easier for people to help you. – Pablo Bianchi Jan 26 at 5:42
  • Since the laptop didn't have much space, my strategy is to run only Lubuntu on the laptop. If I have trouble doing something I'll just connect to the PC in my office to do the job. But the first and foremost is that I could successfully install it on the device. – thetample Jan 26 at 5:47
  • May I ask how did you distribute the partition? My partition distribution / 20G (ext4) /home 4G (ext4) /boot/efi 2G (FAT32) swap 3G (linux swap) Did I missed something here? – thetample Jan 26 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.