0

I'm trying to get fingerprint scanner working but cannot even add repository. I'm new to ubuntu from fedora, maybe I'm doing something wrong, since others seems to be able do that half of year ago ...

so here is this answer: Using Fingerprint reader in 16.04

but first step:

sudo add-apt-repository ppa:fingerprint/fingerprint-gui

LSB codename: 'bionic'.
This codename isn't currently supported.
Please check your LSB information with "lsb_release -a".

and then:

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:   bionic

am I doing anything wrong?

EDIT: so I tried to avoid add-apt-repository command.

I added file /etc/apt/sources.list.d/fingerprint.list with content

deb [arch=amd64] http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic contrib

and then did apt update with errors:

Get:6 http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic InRelease [15,4 kB]     
Hit:10 http://security.ubuntu.com/ubuntu bionic-security InRelease                               
Err:6 http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EFD5FA852F20733F
Reading package lists... Done 
W: GPG error: http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EFD5FA852F20733F
E: The repository 'http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

EDIT2: so IIUC it seems, that there is missing some public key. How can I verify, that repository gpg is OK? I'd like to do that prior to blindly adding public key using:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3C962022012520A0 
sudo apt-get update
  • You should try again. The Fingerprint PPA supports bionic, so it maybe a networking issue. – N0rbert Jan 26 '19 at 16:15
  • tried that several times, same result for 3 days. Is there any diagnostic I can do? – Martin Mucha Jan 26 '19 at 18:26
  • ok, some backstage info: this is company laptop and someone created image for automatic install. Never used this before, but I can imagine that some hash could change in process. But changes made were rather minimal and it still should be the same ubuntu version. So if 18.04 is actually supported reardless of message, is there something what can be done, like forcing the repo or ... ? – Martin Mucha Jan 27 '19 at 8:50
  • Try to visit repository manually ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu/pool/main and get all bionic ( fingerprint-gui , libbsapi , libfprint ) packages from here... – N0rbert Jan 27 '19 at 8:57
  • I understand that's a way, but considering my newbie skillset and long term OS health, it would rather make repositories somehow work. – Martin Mucha Jan 27 '19 at 9:42
5

I know this question is a bit old, and you may have already fixed it, but I've ran through this issue as well, and it took me a couple hours to find out what the hell was happening and what should be done to fix it.

Firstly, a quick question: Did you install Cinnamon Flavour in your Ubuntu distro? (I bet you did)

If so, continue this reading, please.

I wrote a README, as follows, describing what to do to fix it. Hope it'll help others as well! Let me know if you have any questions.

What is this?

This is a tutorial to fix your Cinnamon 4.0 installation on your Ubuntu 18.04 LTS, in case you lost your Software & Updates application, and can't run it through terminal with sudo software-properties-gtk, and neither commands such as sudo add-apt-repository PPA work.

You are probably encountering the following issue when trying to run any of these commands:

LSB codename: 'bionic'.
This codename isn't currently supported.
Please check your LSB information with "lsb_release -a".

Why is this happening?

When you installed Cinnamon through a PPA repository, it also installed a package called mintsources. This package essentially controls the Software Sources package, which is a Linux Mint version of Software & Updates.

This means your Ubuntu version of software-properties-common, software-properties-gtk and python3-software-properties gets replaced by mintsources.

So when you try to run any command that depends on any of these packages, they will try to find what is your Mint distribution, on the folder "/usr/share/mintsources/", and output an error in case your LSB codename differs from any of the existing distros in the folder. See source: mintsources.py.

How To

Undoing this is pretty simple, altough a little difficult to find the solution on the internet.

First off, download the three official packages of Ubuntu into a temporary folder, by running the following commands:

$ mkdir /tmp/cinnamon-fix/
$ cd /tmp/cinnamon-fix/
$ wget http://archive.ubuntu.com/ubuntu/pool/main/s/software-properties/software-properties-gtk_0.96.24.32.1_all.deb http://archive.ubuntu.com/ubuntu/pool/main/s/software-properties/software-properties-common_0.96.24.32.1_all.deb http://archive.ubuntu.com/ubuntu/pool/main/s/software-properties/python3-software-properties_0.96.24.32.1_all.deb

By the time this README was written, these were the latest versions of each package, according to the sources:

Now you should remove the faulty packages:

$ sudo apt remove --purge software-properties-gtk software-properties-common python3-software-properties -y

Last, remove mintsources package so it doesn't replace the packages you are going to install by its Mint version, and install them through dpkg:

PS: make sure you are inside our previously created folder "/tmp/cinnamon-fix/"

$ sudo apt autoremove mintsources -y
$ sudo dpkg -i *

If the first command tells you this action could be potentially harmful, don't be afraid, you can safely continue this.

To make sure a sudo apt update followed by sudo apt upgrade won't force mintsources to be reinstalled and break your system again, you should now remove the PPA repository through regular Software & Updates package.

Only add it again in case you really need to update something related to this PPA, but be aware you'll have to run through this process again.

Done! :)

Additional info at https://forum.level1techs.com/t/upgrading-to-cinnamon-4-0-on-18-04-dont-forget-one-package/135561. Many thanks to the user FurryJackman.

| improve this answer | |
  • 2
    This is the exactly the same answer as askubuntu.com/questions/1113525/… Neither this nor the other question asks about fixing Cinnamon. – user68186 Apr 3 '19 at 13:44
  • It quite doesn't matter what the question's asking if the user who asked it doesn't know the problem's source. I gave him the source problem and the fix to it. BTW, what's the matter of using my same answer in another question that has THE SAME ROOT CAUSE? I spent hours trying to guess the root cause and how could I fix it, and now I just wanted to share it with whoever's having the same issue. Maybe you should simulate the same behavior on your computer and apply this fix before showing total ungratefulness without a reason. Maybe I made a mistake by joining this forum after all. – Lucas Antunes Apr 3 '19 at 18:05
  • Hi Lucas and welcome to the site. I know it is cofusing for new users, but we are not a forum, so we work in different ways. You might want to visit out help center or take the tour to understand this site better. In general, instead of posting the same answer on multiple questions, if the questions are the same, just flag them as duplicates. In this case, the questions are actually different and were asked by the same person, so there's no point in linking to this answer there. I have now deleted the other answer. – terdon Apr 4 '19 at 11:50
  • @user68186 if you read the answer, you'll see that Lucas is getting the exact same error message described in the OP so this is indeed one possible scenario explaining what happened. – terdon Apr 4 '19 at 11:51
  • @terdon Thanks for reviewing the answers and getting back to me. – user68186 Apr 4 '19 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.