0

I'm trying to install the Unifi software on Ubuntu 18.04. The guide I'm following is from the developers of Unifi in the link below:

https://help.ubnt.com/hc/en-us/articles/220066768-UniFi-How-to-Install-and-Update-via-APT-on-Debian-or-Ubuntu

The problem I've got is that I get numerous dependency problems when trying to install the software. In the guide, I get to the point where I run the command below when I run into errors:

$ sudo apt install unifi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 unifi : Depends: mongodb-server (< 1:3.6.0) but 1:3.6.3-0ubuntu1 is to be installed or
                  mongodb-10gen (< 3.6.0) but it is not installable or
                  mongodb-org-server (< 3.6.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
server@Server:~$ sudo apt remove unifi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'unifi' is not installed, so not removed
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

I've tried purging and removing anything and everything to do with mongodb and I still get this same problem at the end. Need some advice on how to get this fixed.

0

I am having the same issue, which is the mongodb-server has to be LESS than 3.6.0 and Ubuntu 18.04 only has the 3.6.3 version to install.

I believe these instructions should work for you, which adds sources to install an "older" version of mongodb-server and the unifi controller:

https://help.ubnt.com/hc/en-us/articles/220066768-UniFi-How-to-Install-Update-via-APT-on-Debian-or-Ubuntu

At least it worked for me.

  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Kevin Bowen Mar 12 at 3:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.